Ubuntu Internet Probleme

Alles, was nicht direkt mit Python-Problemen zu tun hat. Dies ist auch der perfekte Platz für Jobangebote.
Benutzeravatar
Drake
User
Beiträge: 71
Registriert: Mittwoch 14. März 2007, 15:48
Wohnort: Bremen
Kontaktdaten:

Ubuntu Internet Probleme

Beitragvon Drake » Samstag 30. Juni 2007, 21:08

Tag Leute,

Ich habe ein kleines Problem. Ich wollte mir mal (neben XP) ncoh Ubuntu 6.xx installieren, habe das auch getan. Ich weiß, als erstes kommen Postings vonwegen "Ließ dir erstma mal xy durch, sonst vergiss es mit Ubuntu!" etc., das ist mir egal. Zu meinem Problem: Mit Windows XP funktioniert mein Internet (DSL 2k) einwandfrei. Mit Ubuntu habe ich zwar eine Verbindung, jedoch funktioniert diese nicht richtig. z.B. wenn ich google.de aufrufen möchte, dauert dies entweder 5 min. oder es kommt garnichts. Woran könnte das liegen?
Tayce
User
Beiträge: 56
Registriert: Sonntag 22. April 2007, 18:26
Wohnort: München
Kontaktdaten:

Beitragvon Tayce » Samstag 30. Juni 2007, 22:20

Mit was gehst du ins internet? Kabel, Wlan?
Benutzeravatar
Drake
User
Beiträge: 71
Registriert: Mittwoch 14. März 2007, 15:48
Wohnort: Bremen
Kontaktdaten:

Beitragvon Drake » Samstag 30. Juni 2007, 22:22

Ach, sorry. ;)

Ähm .. dLAN? Netwerk über Stromleitung, also praktisch ne LAN Verbindung.
Tayce
User
Beiträge: 56
Registriert: Sonntag 22. April 2007, 18:26
Wohnort: München
Kontaktdaten:

Beitragvon Tayce » Samstag 30. Juni 2007, 22:33

Hmm... dann weiß ich es auch nich...

probier doch einfach mal die 7.04 aus... (die aktuelle ubuntu version)
Benutzeravatar
Drake
User
Beiträge: 71
Registriert: Mittwoch 14. März 2007, 15:48
Wohnort: Bremen
Kontaktdaten:

Beitragvon Drake » Samstag 30. Juni 2007, 22:42

Muss ich dann formatieren/neu installieren oder geht das auch per Update? :/
Tayce
User
Beiträge: 56
Registriert: Sonntag 22. April 2007, 18:26
Wohnort: München
Kontaktdaten:

Beitragvon Tayce » Samstag 30. Juni 2007, 22:52

sollte per update funktionieren...

http://wiki.ubuntuusers.de/Upgrade_auf_Feisty

hier ist ein how-to
querdenker
User
Beiträge: 424
Registriert: Montag 28. Juli 2003, 16:19
Wohnort: /dev/reality

Re: Ubuntu Internet Probleme

Beitragvon querdenker » Sonntag 1. Juli 2007, 14:36

Drake hat geschrieben:Tag Leute,

Ich habe ein kleines Problem. Ich wollte mir mal (neben XP) ncoh Ubuntu 6.xx installieren, habe das auch getan. Ich weiß, als erstes kommen Postings vonwegen "Ließ dir erstma mal xy durch, sonst vergiss es mit Ubuntu!" etc., das ist mir egal. Zu meinem Problem: Mit Windows XP funktioniert mein Internet (DSL 2k) einwandfrei. Mit Ubuntu habe ich zwar eine Verbindung, jedoch funktioniert diese nicht richtig. z.B. wenn ich google.de aufrufen möchte, dauert dies entweder 5 min. oder es kommt garnichts. Woran könnte das liegen?

Das klingt für mich nicht nach einem Distri-Problem.
Schau dir mal die Einstellungen bezüglich DNS, Gateway und host an.
Wo das unter Ubuntu ist, kann ich dir nicht sagen. Benutze archlnux

Noch was : Ausgabe von ipconfig /all und ifconfig vergleichen. Die sollten, wenn du alles richtig gemacht hast, fast identische Ausgaben erzeugen.
Und was sagt dein Browser eigentlich? Mal versucht, eine Seite einmal über Name, einmal über IP anzupingen? Traceroute kann dir da auch helfen. DIe Abfragen unter WinXP und unter Linux machen, Ausgabe vergleichen.

syl, querdenker
fme
User
Beiträge: 34
Registriert: Sonntag 1. April 2007, 18:58
Wohnort: Bremen

Beitragvon fme » Sonntag 1. Juli 2007, 15:03

Könnte ein Problem mit dem DNS-Server sein.

Als erstes Versuche mal bitte im Browser
http://216.239.59.104/
aufzurufen.

Hängt es immer noch, dann versuche mal in der Konsole ein

Code: Alles auswählen

dig google.de

Solltest eine Ausgabe ähnlich wie

Code: Alles auswählen

fme@fme-nb:~$ dig google.de

; <<>> DiG 9.3.4 <<>> google.de
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4869
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;google.de.                     IN      A

;; ANSWER SECTION:
google.de.              1485    IN      A       216.239.59.104
google.de.              1485    IN      A       72.14.221.104
google.de.              1485    IN      A       66.249.93.104

;; Query time: 97 msec
;; SERVER: 192.168.2.1#53(192.168.2.1)
;; WHEN: Sun Jul  1 16:06:59 2007
;; MSG SIZE  rcvd: 75

fme@fme-nb:~$   
bekommen.

Sollte sich die Ausgabe dort auch ewig verzögern, dann
verwende mal einen anderen DNS-Server in der /etc/resolv.conf
Benutzeravatar
Drake
User
Beiträge: 71
Registriert: Mittwoch 14. März 2007, 15:48
Wohnort: Bremen
Kontaktdaten:

Beitragvon Drake » Sonntag 1. Juli 2007, 16:31

Jetzt bin ich um einiges weiter ..

Also per IP geht es perfekt!

Allerdings kann ich die resolv.conf nicht ändern .. Ich bin mit meinem Account (marc) eingeloggt, der theoretisch alle Recht ehaben sollte. Ich kann diese Datei allerdings nicht verändern, angeblich habe ich nur Leserechte. Wenn ich mit dann mit root einloggen will, lese ich das der Systemadministrator sich nicht von diesem Bildschirm einloggen kann/darf .. Kann mir das mal einer erklären?
Benutzeravatar
veers
User
Beiträge: 1219
Registriert: Mittwoch 28. Februar 2007, 20:01
Wohnort: Zürich (CH)
Kontaktdaten:

Beitragvon veers » Sonntag 1. Juli 2007, 16:54

Ubuntu verwendet sudo. Das ist so konfiguriert das dein standard Benutzer Root-Rechte erlangen kann. Dies musst du jedoch mit deinem Passwort bestätigen. Gehen tut das ganz einfach:
$ sudo vim /etc/resolve.conf
;)

Cheers,
Jonas
lunar

Beitragvon lunar » Sonntag 1. Juli 2007, 17:00

Drake hat geschrieben:Allerdings kann ich die resolv.conf nicht ändern .. Ich bin mit meinem Account (marc) eingeloggt, der theoretisch alle Recht ehaben sollte.

Nein. Dein Account hat nicht alle Rechte, die hat nur root. Du kannst allerdings von deinem Account aus über sudo Root-Privilegien erlangen.

Ich kann diese Datei allerdings nicht verändern, angeblich habe ich nur Leserechte.

Das ist auch richtig so, kein Useraccount darf an Systemdateien rummanipulieren.

Wenn ich mit dann mit root einloggen will, lese ich das der Systemadministrator sich nicht von diesem Bildschirm einloggen kann/darf ..

Man kann sich bei Ubuntu weder graphisch noch auf der Konsole als root einloggen, dieser Account ist deaktiviert. Stattdessen musst du sudo verwenden. Graphisch sollte man sich nirgendwo als root einloggen, da der X Server nicht die sicherste Software ist, und relativ einfach manipuliert werden kann.

Das sind aber eigentlich grundlegende Sache für jeden Ubuntu-User. Du solltest dir diese Grundlagen mal anlesen. Ich kann dir da das Ubuntuusers Wiki empfehlen:
http://wiki.ubuntuusers.de/sudo
Benutzeravatar
Drake
User
Beiträge: 71
Registriert: Mittwoch 14. März 2007, 15:48
Wohnort: Bremen
Kontaktdaten:

Beitragvon Drake » Sonntag 1. Juli 2007, 17:58

//Edit: Erledigt! Internet funktioniert. Danke an alle, ohne euch hätt ichs nich gschafft.
Benutzeravatar
Drake
User
Beiträge: 71
Registriert: Mittwoch 14. März 2007, 15:48
Wohnort: Bremen
Kontaktdaten:

Beitragvon Drake » Sonntag 1. Juli 2007, 18:39

Ach, bevor ich nen neuen Thread eröffne, poste ich doch nochmal hier. ^^

ALso mein Problem: Ich bin öfter mit ein paar Freunden im Teamspeak. Habs mir auch mal bei Ubuntu runtergeladen. Nun höre ich alles, aber man hört mich nicht .. Die Lampe leuchtet trotzdem (für Leute die TS kennen ;)) Woran kann das liegen?
Benutzeravatar
Sr4l
User
Beiträge: 1091
Registriert: Donnerstag 28. Dezember 2006, 20:02
Wohnort: Kassel
Kontaktdaten:

Beitragvon Sr4l » Sonntag 1. Juli 2007, 19:49

Leuchtet deine Lampe wenn du sprichst oder immer?

Wenn die Lampe immer leuchtet wird dein Sound In nicht funktionieren.
Versuch doch mal mit dem "Audio-Recorder" etwas aufzunehmen (Unterhaltungsmedien),

Verusch da auch mal alle Eingänge durch.
fme
User
Beiträge: 34
Registriert: Sonntag 1. April 2007, 18:58
Wohnort: Bremen

Beitragvon fme » Montag 2. Juli 2007, 11:24

Du muss im Mixer die Eingänge dafür aktivieren.
Das war bei mir jedenfalls das Problem.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder