Python und s60 von Nokia

Probleme bei der Installation?
Antworten
Mad_Zero
User
Beiträge: 3
Registriert: Donnerstag 8. März 2007, 14:33

Donnerstag 8. März 2007, 14:43

Hi Leute, wollte mich gerade mal mit dem S60 von Nokia auseinandersetzen. Also nun bin ich auf folgendes Problem gestoßen. Habe soweit alles installiert, und wenn ich etwas Programmiere funzt es auf dem Handy und auf dem Emulator von Nokia - soweit so gut, nun ist es aber etwas umständlich...
Also wollt ich das nun mit Python 2.5 machen, dabei hab ich es nicht gebacken bekommen die S60 Module zu benutzen. z.B. wollt ich wie gewohnt "import appuifw" aufrufen. Geht hier aber nicht, gibt es da eine Lösung???
Vielleicht könnte ihr mich mal aufklären. Gruß Mad
BlackJack

Donnerstag 8. März 2007, 16:10

Hast Du das Modul für Python 2.5 auch installiert? Bzw. gibt es die entsprechenden Binärmodule für 2.5 überhaupt?
Mad_Zero
User
Beiträge: 3
Registriert: Donnerstag 8. März 2007, 14:33

Donnerstag 8. März 2007, 17:11

Nein leider keine Binärmodule, zumindest find ich keine, aber ich glaub es gibt keine andere lösung, als den emulator jedes mal zu nutzen.

Oder kennt einer noch ne Möglichkeit???
BlackJack

Donnerstag 8. März 2007, 17:50

Nicht Python 2.5 benutzen!?
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Donnerstag 8. März 2007, 18:49

Mad_Zero hat geschrieben:Oder kennt einer noch ne Möglichkeit???
Wenn es Sourcen für CPython gibt, kannst du sie auch für Python 2.5 kompilieren.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
rudi
User
Beiträge: 7
Registriert: Freitag 11. Mai 2007, 11:56

Freitag 11. Mai 2007, 12:02

Mad_Zero hat geschrieben:Hi Leute, wollte mich gerade mal mit dem S60 von Nokia auseinandersetzen. Also nun bin ich auf folgendes Problem gestoßen. Habe soweit alles installiert, und wenn ich etwas Programmiere funzt es auf dem Handy und auf dem Emulator von Nokia - soweit so gut
das versuche ich schon die ganze zeit. nur schaffe ich es nicht pyton auf dem nokia simulator laufen zu lassen. ich versuch mich an dem pdf(get startet with python oder so) zu halten. aber ich schaffe es nicht das sdk von pyton so zu installieren das es mir zur verfügung steht im emulator
Mad_Zero
User
Beiträge: 3
Registriert: Donnerstag 8. März 2007, 14:33

Montag 14. Mai 2007, 08:22

Hey

also wenn du den Emulator installiert hast und er auch funzt, brauchst du nur noch aus der "PythonForS60_1_3_18_SDK_3rdEd_selfsigned.zip" das Verzeichniss "epoc32" in das Symbianverzeichniss kopieren. also z.B. "C:\Symbian\9.2\S60_3rd_FP1\Epoc32". dann sollte es gehen. Also dann hast du wenn du den Emulator startest unter Programme das Pytonsymbol
Antworten