Colubrid Applukationen mit mod_python laufen lassen...

Sockets, TCP/IP, (XML-)RPC und ähnliche Themen gehören in dieses Forum
Antworten
EnTeQuAk
User
Beiträge: 986
Registriert: Freitag 21. Juli 2006, 15:03
Wohnort: Berlin
Kontaktdaten:

Mittwoch 13. Dezember 2006, 14:27

Hallo alle zusammen! :)

Ich versuche gerade verzweifelt meine Test Anwendung von Colubrid:

Code: Alles auswählen

#!/usr/bin/env python
#-*- coding:utf-8 -*-

from colubrid import RegexApplication, HttpResponse

class Mainpage(RegexApplication):
    urls=[
        (r'^$', 'index'),
    ]
    slash_append = True
    
    def index(self):
        return HttpResponse('Du hast mich geruuuufen!')

app = Mainpage

#if __name__ == '__main__':
#    execute(app=app, port=80, host='localhost', reload=True)
laufen zu lassen.

laut der Bsp. Configuration bei Django benötigt man einen mod_python Handler.
Meine httpd.conf sieht folgend aus:

Code: Alles auswählen

NameVirtualHost 88.198.26.9

<VirtualHost 88.198.26.9>
ServerName www.daucms.de
ServerAlias daucms.de *.daucms.de
DocumentRoot /var/www/daucms.de
</VirtualHost>


<Location "/var/www/daucms.de/">
    SetHandler python-program
    AddHandler mod_python .py
    PythonHandler mod_python.publisher
    PythonDebug On
</Location>
So. In meinen Augen sollte es eigentlich laufen oder?
Wenn ich nun meine Datei direkt aufrufe:
http://daucms.de/daucms_app.py

Allerdings findet er die net... obwohl die existiert. CGI-Scripte kann ich außerhalb von /cgi-bin/ ausführen und auch die Endung *.py sollte exakt interpretiert werden.

Um mod_python bei mir vefügbar zu machen habe ich folgendes in meine apache.conf eingefügt:

Code: Alles auswählen

# To use CGI scripts outside /cgi-bin/:
#
AddHandler cgi-script .py
 
# fuer mod_python Support
<IfModule mod_python.c>
        AddHandler mod_python .py
        PythonHandler mod_python.publisher
        PythonDebug On
</IfModule>
Nur so richtig geht das alles net :'(

Was mache ich falsch?
Es muss doch irgentwie gehen... :)
Oder ich muss zwangsweise Django nehmen? Ne oda? :D

MfG EnTeQuAk
Benutzeravatar
xStream
User
Beiträge: 24
Registriert: Dienstag 15. Februar 2005, 21:39

Mittwoch 13. Dezember 2006, 14:51

EnTeQuAk
User
Beiträge: 986
Registriert: Freitag 21. Juli 2006, 15:03
Wohnort: Berlin
Kontaktdaten:

Mittwoch 13. Dezember 2006, 14:58

Also doch Django, bis es läuft... *grml*


Schade... aber wenns läuft bin ich wieder dabei! :D


MfG EnTeQuAk
mitsuhiko
User
Beiträge: 1790
Registriert: Donnerstag 28. Oktober 2004, 16:33
Wohnort: Graz, Steiermark - Österreich
Kontaktdaten:

Mittwoch 13. Dezember 2006, 15:16

xStream hat geschrieben:http://trac.pocoo.org/ticket/132
Das betrifft nur pocoo

@topicstarter: du brauchst ein wsgi gateway für mod_python. Google sollte dir ein paar liefern können.
TUFKAB – the user formerly known as blackbird
EnTeQuAk
User
Beiträge: 986
Registriert: Freitag 21. Juli 2006, 15:03
Wohnort: Berlin
Kontaktdaten:

Donnerstag 14. Dezember 2006, 10:50

Ich bin nun schon ein ganzes Stückchen weiter.

mod_python will zumindest anspringen :) Aber nicht arbeiten. ICh habe nun den Handler von Pocoo genommen
http://trac.pocoo.org/browser/modpywsgi/modpywsgi.py

Den darf/kann ich doch unverändert verändern oder?

Ich bekomme nun nur noch einen Fehler, den ich auf modpy.py (den Handler.. -- name geändert) zurückführe.

siehe http://daucms.de/

ist das der Handler, der in obigem Ticket beschrieben wird?

MfG EnTeQuAk

EDIT:
weiterhin probiere ich gerade an http://projects.amor.org/misc/svn/modpython_gateway.py herum. Auch hier scheint es Probleme zu geben.
mitsuhiko
User
Beiträge: 1790
Registriert: Donnerstag 28. Oktober 2004, 16:33
Wohnort: Graz, Steiermark - Österreich
Kontaktdaten:

Donnerstag 14. Dezember 2006, 13:46

EnTeQuAk hat geschrieben:Ich bekomme nun nur noch einen Fehler, den ich auf modpy.py (den Handler.. -- name geändert) zurückführe.

siehe http://daucms.de/

Code: Alles auswählen

PythonOption application yourapplication.module::YourApplication
Genaueres steht im Docstring
TUFKAB – the user formerly known as blackbird
EnTeQuAk
User
Beiträge: 986
Registriert: Freitag 21. Juli 2006, 15:03
Wohnort: Berlin
Kontaktdaten:

Donnerstag 14. Dezember 2006, 14:27

WUNDERBAR!!!!!!

Klasse! Meine erste WSGI-Anwendung, die mit mod_python rennt :)
http://daucms.de/

So und nun fehlt nur noch FastCGI und dann bin ich oberglücklich :)

Herzlichen Dank euch allen!


MfG EnTeQuAk

EDIT:
FastCGI rennt nun auch noch :) ich bin so happy!
Antworten