Probleme mit Button Link im IE

Sockets, TCP/IP, (XML-)RPC und ähnliche Themen gehören in dieses Forum
Antworten
00eraser00
User
Beiträge: 36
Registriert: Donnerstag 28. September 2006, 12:21

Donnerstag 19. Oktober 2006, 09:45

Hallo.

Ich habe in Plone einen Klick Button erstellt, der beim Anklicken weiterverlinkt.
Firefox macht die Verlinkung und bei IE passiert nix.
Was kann da der Fehler sein?
Hier der Quelltext:

<a href="/phasenmodell/index_html"><input type="button" name="zurück zum Phasenmodell" value="zurück zum Phasenmodell" /></a>
Benutzeravatar
gerold
Python-Forum Veteran
Beiträge: 5555
Registriert: Samstag 28. Februar 2004, 22:04
Wohnort: Oberhofen im Inntal (Tirol)
Kontaktdaten:

Donnerstag 19. Oktober 2006, 10:02

00eraser00 hat geschrieben:

Code: Alles auswählen

<a href="/phasenmodell/index_html">
  <input type="button" name="zurück zum Phasenmodell" value="zurück zum Phasenmodell" />
</a>
Hi Eraser!

Buttons sind eigentlich nur für die Verwendung in Formularen gedacht. Wenn du einem Button eine Aktion zuweisen möchtest, dann musst du JavaScript verwenden oder die Weiterleitung per Forumularaktion einstellen. Einen Button einfach innerhalb eines Anker-Tags stellen, funktioniert leider nicht korrekt.

Siehe:
- http://de.selfhtml.org/html/formulare/klickbuttons.htm
- http://de.selfhtml.org/html/formulare/f ... uttons.htm
- http://de.selfhtml.org/html/formulare/index.htm

mfg
Gerold
:-)

PS: Codehighlighting
http://halvar.at | Kleiner Bascom AVR Kurs
Wissen hat eine wunderbare Eigenschaft: Es verdoppelt sich, wenn man es teilt.
00eraser00
User
Beiträge: 36
Registriert: Donnerstag 28. September 2006, 12:21

Donnerstag 19. Oktober 2006, 10:46

dankeeee es geht :-)
Antworten