M2Crypto SWIG installation mit Py2.4

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
uz
User
Beiträge: 5
Registriert: Sonntag 30. Juli 2006, 09:10

M2Crypto SWIG installation mit Py2.4

Beitragvon uz » Donnerstag 10. August 2006, 15:39

Hi,
ich habe das Problem dass ich das M2Crypto Paket nicht installiert bekomme. Jedesmal wenn ich es versuche bekomme ich folgende Fehlermeldung:
C:\m2crypto-0.13\m2crypto-0.13>python setup.py build
running build
running build_py
running build_ext
building '__m2crypto' extension
Traceback (most recent call last):
File "setup.py", line 96, in ?
ext_modules = [m2crypto]
File "c:\python24\lib\distutils\core.py", line 149, in setup
dist.run_commands()
File "c:\python24\lib\distutils\dist.py", line 946, in run_com
self.run_command(cmd)
File "c:\python24\lib\distutils\dist.py", line 966, in run_com
cmd_obj.run()
File "c:\python24\lib\distutils\command\build.py", line 112, i
self.run_command(cmd_name)
File "c:\python24\lib\distutils\cmd.py", line 333, in run_comm
self.distribution.run_command(command)
File "c:\python24\lib\distutils\dist.py", line 966, in run_com
cmd_obj.run()
File "c:\python24\lib\distutils\command\build_ext.py", line 27
self.build_extensions()
File "c:\python24\lib\distutils\command\build_ext.py", line 40
nsions
self.build_extension(ext)
File "c:\python24\lib\distutils\command\build_ext.py", line 44
nsion
sources = self.swig_sources(sources, ext)
TypeError: swig_sources() takes exactly 2 arguments (3 given)


Kennt jemand dieses Problem und hat eine Lösung dafür?
Ich benutze WinXP, Python 2.4, MinGW3.6, swigwin-1.3.23, openssl-0.9.8b und möchte m2crypto-0.13 verwenden.

Vielen Dank
ciao
uz

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot], Kebap