Windows installation

Probleme bei der Installation?
fahne
User
Beiträge: 2
Registriert: Montag 26. Juni 2006, 17:04
Kontaktdaten:

Windows installation

Beitragvon fahne » Montag 26. Juni 2006, 17:11

Hallo,
ich hab mir den 'Python 2.4.3 Windows installer' heruntergeladen und installiert, sollte ja eigentlich kein Problem sein. Hat auch funktioniert, aber die import funktion scheint nicht richtig zu funktionieren, und ich ahbe absolut keine Idee woran das liegen könnte. wenn ich

Code: Alles auswählen

import urllib
oder auch

Code: Alles auswählen

import urllib2
oder ... eingebe kommt folgende Fehlermeldung:

Code: Alles auswählen

Traceback (most recent call last):
  File "<stdin>", line 1, in ?
ImportError: No module named urllib(2)

Ich hoffe, dass einer von euch mir helfen kann.

Gruß Jens
Benutzeravatar
gerold
Python-Forum Veteran
Beiträge: 5554
Registriert: Samstag 28. Februar 2004, 22:04
Wohnort: Telfs (Tirol)
Kontaktdaten:

Re: Windows installation

Beitragvon gerold » Montag 26. Juni 2006, 17:28

fahne hat geschrieben:Hat auch funktioniert, aber die import funktion scheint nicht richtig zu funktionieren, und ich ahbe absolut keine Idee woran das liegen könnte.

Hi Jens!

Hier ein paar Ideen:

- Computer schon neu gestartet?

- Start-Ausführen-cmd-python --> startet sich auch wirklich das neue Python 2.4.3?

- Python komplett deinstallieren --> neu starten --> Python noch einmal installieren --> neu starten

- Verwendest du diese Datei? http://python.org/ftp/python/2.4.3/python-2.4.3.msi

- Was gibt "sys.path" zurück? Vielleicht wird der Python-Pfad nicht richtig gesetzt.

- Bist du beim Installieren als ein Administrator angemeldet?

mfg
Gerold
:-)
http://halvar.at | Kleiner Bascom AVR Kurs
Wissen hat eine wunderbare Eigenschaft: Es verdoppelt sich, wenn man es teilt.
fahne
User
Beiträge: 2
Registriert: Montag 26. Juni 2006, 17:04
Kontaktdaten:

Re: Windows installation

Beitragvon fahne » Montag 26. Juni 2006, 18:10

- Computer schon neu gestartet?


ja

- Start-Ausführen-cmd-python --> startet sich auch wirklich das neue Python 2.4.3?


ja, es ist keine alte Verssion vorhanden

- Python komplett deinstallieren --> neu starten --> Python noch einmal installieren --> neu starten


gerade eben erst versucht, leider erfolglos



ja

- Was gibt "sys.path" zurück? Vielleicht wird der Python-Pfad nicht richtig gesetzt.


Daran lags, hatte mal XAMPP mit Python installiert, davon waren noch überreste

- Bist du beim Installieren als ein Administrator angemeldet?



Ja, war ich, hat sich ja jetzt eh erledigt, es funktioniert jetzt alles. Vielen Dank für die schnelle Hilfe

Gruß Jens

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder