SPE unter Suse 10.1

Probleme bei der Installation?
Antworten
Benutzeravatar
Mawilo
User
Beiträge: 446
Registriert: Sonntag 22. Februar 2004, 10:58
Wohnort: Sachsen
Kontaktdaten:

Montag 26. Juni 2006, 14:27

Hallo,

ich wollte auf meinem Rechner mal den SPE (Stani's Python Editor) installieren. Leider bin ich da hängengeblieben. Beim Installieren des rpm-Packetes bekomme ich folgende Meldung über eine fehlende Abhängigkeit:

Code: Alles auswählen

error: Failed dependencies:
        python(abi) = 2.4 is needed by spe-0.8.2a-1.i386
Ich habe alles, was irgendwie nach Python riecht, auf meinem Rechner.
Was ist aber python(abi)?

OS: Suse Linux 10.1
Python 2.4.2

Stephan
Benutzeravatar
Rebecca
User
Beiträge: 1662
Registriert: Freitag 3. Februar 2006, 12:28
Wohnort: DN, Heimat: HB
Kontaktdaten:

Montag 26. Juni 2006, 14:59

ABI: Application Binary Interface

python(abi) ist einfach das Python-Paket. Hast du denn dein Python auch via rpm installiert? Wenn nicht, kann der Paketmanager gar nicht wissen, das Python da ist. Ansonsten ist vlt. das SPE-rpm nicht in Ordnung.

Du koenntest es auf jeden Fall mit der rpm-Option --nodeps versuchen, das unterdrueckt den Dependency-Check.
Benutzeravatar
Mawilo
User
Beiträge: 446
Registriert: Sonntag 22. Februar 2004, 10:58
Wohnort: Sachsen
Kontaktdaten:

Montag 26. Juni 2006, 15:24

Das scheint an meiner wxGTK-Version zu liegen. Eine neuere version habe ich nich nicht gefunden.
Ich bekomme jetzt folgende Meldung:

Code: Alles auswählen

rpm -i --nodeps spe-0.8.2a-wx2.6.1.0-py2.4.rpm
        file /usr/bin/helpviewer from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/img2png from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/img2py from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/img2xpm from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/pyalacarte from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/pyalamode from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/pycrust from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/pyshell from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/pywrap from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/pywxrc from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/bin/xrced from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
        file /usr/lib/python2.4/site-packages/wx.pth from install of spe-0.8.2a-1 conflicts with file from package python-wxGTK-2.6.2.1-20
Python (incl. devel-Packet) wurde alles als rpm-Packet installiert.
Antworten