cPickle defekt

Probleme bei der Installation?
murph
User
Beiträge: 622
Registriert: Freitag 14. April 2006, 19:23
Kontaktdaten:

cPickle defekt

Beitragvon murph » Freitag 16. Juni 2006, 19:45

hi!
ich habe probleme mit cpickle!
murph@murphs:~/My Downloads/panda3d-1.2.3/makepanda$ ./makepanda.py
Traceback (most recent call last):
File "./makepanda.py", line 15, in ?
import sys,os,time,stat,string,re,getopt,cPickle,fnmatch,threading,Queue,signal
ImportError: /usr/lib/python2.4/lib-dynload/cPickle.so: undefined symbol: PyUnicodeUCS4_AsUTF8String

in dem modul scheinen falsche symbooole zu sein...aber ich habe nix gemacht, wieso klappts dann bei den annern? (*rethorik*)
habt ihr eine ahnung, was das problem sein könnte?
kann mir die datei leider nicht ansehen, da sie binär ist und ich über cat nicht weiß, wie man in die einzelnen zeilen springt (falls es am kommentar leigen sollte) ...
BlackJack

Beitragvon BlackJack » Freitag 16. Juni 2006, 21:37

Bekommst Du die gleiche Fehlermeldung wenn Du `cPickle` im interaktiven Interpreter importierst?
murph
User
Beiträge: 622
Registriert: Freitag 14. April 2006, 19:23
Kontaktdaten:

Beitragvon murph » Samstag 17. Juni 2006, 20:14

ja, so ist das leider...

//edit: ich habe keine ahnung, ob das zusammengehört, aber ich habe grad gesehen, dass mein Tkinter auch macken macht:
>>> import Tkinter
Traceback (most recent call last):
File "<stdin>", line 1, in ?
File "/usr/lib/python2.4/lib-tk/Tkinter.py", line 38, in ?
import _tkinter # If this fails your Python may not be configured for Tk
ImportError: /usr/lib/python2.4/lib-dynload/_tkinter.so: undefined symbol: PyFPE_jbuf

die anderen guis funzen...ich habe tkinter danach neu installiert via apt-get,
hat nichts geholfen.
murph
User
Beiträge: 622
Registriert: Freitag 14. April 2006, 19:23
Kontaktdaten:

Beitragvon murph » Sonntag 18. Juni 2006, 18:04

sehe ich es richtig, dass ihr (leider^^) das problem noch nicht hattet? schade, denn tkinter brauch man ja allemal...und cPickle ebenfalls
Benutzeravatar
Gromit
User
Beiträge: 51
Registriert: Montag 8. Mai 2006, 19:07

Beitragvon Gromit » Sonntag 18. Juni 2006, 18:27

Sieht schwer danach aus, als ob dein python.so nicht zu deinem extension modulen passt.
Hast du vielleicht mal selbst ein python kompiliert, installiert und dann nur halb gelöscht?

Mit python hat ich sowas noch nicht, wohl aber mit diversen anderen Programmen.

HTH,
Gerald
Python 47
User
Beiträge: 574
Registriert: Samstag 17. September 2005, 21:04

Beitragvon Python 47 » Sonntag 18. Juni 2006, 18:28

Wie wäre es mit einer kompletten neuinstallation? :?
mfg

Thomas :-)
murph
User
Beiträge: 622
Registriert: Freitag 14. April 2006, 19:23
Kontaktdaten:

Beitragvon murph » Sonntag 18. Juni 2006, 18:41

cPickle habe ich noch nicht neu gefunden, mit Tkinter habe ich es versucht.
und python neu zu installieren wäre selbstmord, das ist ins system integriert und ganze anwendungen basieren darauf.
BlackJack

Beitragvon BlackJack » Sonntag 18. Juni 2006, 22:26

`cPickle` gehört zur Standardbibliothek. Wenn das kaputt ist, dann ist Dein Python kaputt. Da kommst Du um's neuinstallieren nicht herum.

Schau Dir mal die Module in Deiner Python-Installation unter `/lib-dynload/*` an ob da noch mehr Probleme bereiten.
murph
User
Beiträge: 622
Registriert: Freitag 14. April 2006, 19:23
Kontaktdaten:

Beitragvon murph » Dienstag 20. Juni 2006, 20:04

dann lass ich das erstmal, möchte den noch ein bisschen nutzen, die anderen sachen funktionieren ja problemlos.(hoffe ich doch^^)

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder