etwas kompliziert :-), builtin module, linux, lib-dyn

Probleme bei der Installation?
Antworten
alexPixel
User
Beiträge: 1
Registriert: Montag 2. Juni 2003, 06:11

Montag 2. Juni 2003, 06:28

hallo zusammen

bin neu hier, also erstmal hallo zusammen :-)

Hier mein Problem:
Ich benutze Blender in dem python integriert ist (leider nur version 2.0)
Für Blender gibt es eine windows und eine linux version.
Blender benutzt eine eigene version von python, in der nicht alle builtin module zur verfügung stehen und diese von einer anderen python installation nachgeladen werden können.

Das Problem was ich habe betrifft das socket modul. Wenn ich das socket modul importiere bedingt das, das auch das _socket modul vorhanden ist.
In Win Python 2.0 wird das _socket modul zur laufzeit dazu geladen.
In Linux Python 2.0 ist das socket modul schon integriert (in Version 2.2 wird es auch dynamisch geladen)
Wenn ich in Linux in Blender das modul socket importiere kommt der fehler _socket not found.

Wie kann ich Python 2.0 unter linux so kompilieren das _socket zu _socket.so wird und nicht in das python binary integriert wird?

Möchte eigentlich viel lieber unter gentoo linux arbeiten als unter w2k :-)
Das blöde Problem hat mich schon eine ganze nacht gekostet grrrrrrrr

gruss
Antworten