MySQl mod_python geht überhaubt nicht :(

Sockets, TCP/IP, (XML-)RPC und ähnliche Themen gehören in dieses Forum
mono

MySQl mod_python geht überhaubt nicht :(

Beitragvon mono » Dienstag 29. November 2005, 13:00

Hi,

ich versuch mich etwas mit mod_python und psp.

Klappt auch soweit alles ganz gut nur mysql will nicht

folgendes Beispiel

Code: Alles auswählen

from mod_python import psp

import MySQLdb

def _navi(level):
        #Verbindung zur Datenbank:
        connection = MySQLdb.connect(
                host="localhost",
                db="createlog",
                user="----------",
                passwd="-----------")

        #Erstelle Dict Cursor
        curser = connection.cursor()

        query = """SELECT * from page"""
        curser.execute(query)

        result = curser.fetchall()
        connection.commit()

        navi = result
        return navi


def index(req, sitename=''):

        name = "home"

        if sitename:
                name = sitename

        req.content_type = 'text/html'

        main_tmpl = psp.PSP(req, filename='templ/main.tmpl')

        title = "test text hallo"
        main = "test content main"
        navi_tmpl = _navi(2)

        hello_tmpl.run(vars = { 'cont_title': title, 'cont_main': main, 'cont_navi': navi_tmpl })

        return



verursacht im apache2 log

Code: Alles auswählen

[Tue Nov 29 12:49:46 2005] [notice] mod_python: (Re)importing module 'mod_python.publisher'
[Tue Nov 29 12:49:46 2005] [notice] mod_python: (Re)importing module 'index' with path set to '['/home/www/default/htdocs']'
[Tue Nov 29 12:49:47 2005] [notice] child pid 7797 exit signal Segmentation fault (11)


Im Browser tut sich garnix keine neue Seite einfach nix.

Der mysql Code auf der Konsole funktioniert aber. Muss man da noch was beachten oder geht das mit mod_python komplett anders?

Danke schon mal
Gast

Beitragvon Gast » Dienstag 29. November 2005, 13:51

ok ich hab den Fehler gefunden.
MySQL und auch andere Libs machen wohl Probleme in Verbindung mit PHP.

Wenn ich PHP abschalte gehst.

Nur leider Brauch ich eigentlich auch PHP bzw. andere auf dem Server.

Habt ihr ähnliche Probleme?

Ich nutze Ubuntu werde aber gleich noch auf nem debian sarge mal testen.

--> http://www.modpython.org/FAQ/faqw.py?re ... 02.013.htp
henning
User
Beiträge: 274
Registriert: Dienstag 26. Juli 2005, 18:37

Beitragvon henning » Dienstag 29. November 2005, 15:40

Wird dir nicht helfen, aber ich habe das Problem auch und lasse PHP bei mir abgeschaltet, weil ich es vorher eh nur für phpmyadmin genutzt habe (Nutze jetzt stattdessen mysql-admin und mysql-query-browser).

Wenn dus halt gar nicht anders hinkriegst und unbedingt mod_python und php brauchst, musst du halt php und mod_python von hand backen wie in deinem Link beschrieben...

Ansonsten könnte man mal ausprobieren, wie sich das verhält, wenn man zwei Instanzen von apache parrallel laufen lässt, ist natürlich _noch_ hässlicher, weil die dann nicht beide auf Port 80 horchen können :-/
raist1314
User
Beiträge: 52
Registriert: Dienstag 21. September 2004, 06:58
Wohnort: Adelzhausen
Kontaktdaten:

Beitragvon raist1314 » Dienstag 29. November 2005, 20:10

Ein Tip von meiner Seite... vergiss mod_python. Der Ärger den Du damit haben wirst, kannst du Dir vorher ersparen... Achte mal hier im Forum auf die ganze Diskussion betreffend WSGI und wenn du dazu Fragen hast, kann dir Blackbird sicher weiterhelfen :wink:

Sebastian

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder