Fehlermeldung Python (bin Anfänger)

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
Antworten
Pittiplatsch

Donnerstag 6. Oktober 2005, 23:19

Hallo...

bin noch ein sehr doller anfänger...

ich habe python runtergeladen, und istalliert, muss ich noch was anderes machen? konfig oder sowas`?


denn ich habe folgenden fehler (oder sind das gleich mehrere), in einem eigentlich fertigen script, aber da ich anfänger bin, weis ich nich was der bedeutet....

Code: Alles auswählen

Traceback (most recent call last):
  File "C:\Programme\python\Lib\S-interpreter-python-11\gui.py", line 475, in -toplevel-
    ampel_interpreter = interpreter.Interpreter ()
  File "C:\Programme\python\Lib\S-interpreter-python-11\interpreter.py", line 47, in __init__
    self.parser =parser.Parser ()
AttributeError: 'module' object has no attribute 'Parser'
ich würde mich echt freuen, wenn mir da jemand vom fach helfen kann...

vielen dank im voraus...

mfg
reggid
User
Beiträge: 120
Registriert: Dienstag 8. Oktober 2002, 19:04
Wohnort: Dinslaken
Kontaktdaten:

Freitag 7. Oktober 2005, 08:34

Kurze Frage vorweg woher hast du den script? Selbstgeschrieben oder runtergeladen?

Code: Alles auswählen

  File "C:\Programme\python\Lib\S-interpreter-python-11\interpreter.py", line 47, in __init__
    self.parser =parser.Parser ()
AttributeError: 'module' object has no attribute 'Parser'
Diese Fehlermeldung heißt einfach nur, dass dein Module(in diesem Falle Parser) das Attribut Parser nicht hat.

Aus der ersten Fehlermeldung kann ich mir gerade kein Reihm machen, aber irgendwie kommt mir das alles komisch vor...
Vielleicht bin ich ja auch noch zu müde... :)
Benutzeravatar
jens
Moderator
Beiträge: 8482
Registriert: Dienstag 10. August 2004, 09:40
Wohnort: duisburg
Kontaktdaten:

Freitag 7. Oktober 2005, 08:59

Pittiplatsch hat geschrieben:in einem eigentlich fertigen script
Was ist denn dieses script???

CMS in Python: http://www.pylucid.org
GitHub | Open HUB | Xing | Linked in
Bitcoins to: 1JEgSQepxGjdprNedC9tXQWLpS424AL8cd
Gast

Freitag 7. Oktober 2005, 11:50

das script ist von dem Bundeswettbewerb für Informatik. Dabei soll es sich um eine Ampelschaltung handeln. Diese Aufgabe ist eine aus dem Jahr 2002/2003. Die Aufgabe selbst findet Ihr Hier von dort lud ich mir, das mir denke ich fertige script für python herunter. In dem .zip Archive befinden sich mehrere Dateien, jedoch probierte ich nur die gui.py zu starten, denn damit soll das programm dann eigentlich, laut der in dem .zip Archive befindlichen Readme, starten.

Ich wäre echt sehr glücklich, wenn ihr mir da helfen könntet.

vielen dank im voraus.

MfG
Joghurt
User
Beiträge: 877
Registriert: Dienstag 15. Februar 2005, 15:07

Freitag 7. Oktober 2005, 12:36

Hast du die Datei direkt aus dem ZIP gestartet? Du wirst wohl erstmal das gesamte ZIP entpacken müssen, und dann davon starten.
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Freitag 7. Oktober 2005, 12:44

Tu das Script doch aus C:\Programme\Python\libs woandershin, dort sollte man sowas nicht reintun.

Ich wollte das auch grad bei mir testen: grad gemerkt, dass ich Tkinter wegrationalisiert habe :D
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Pittiplatsch

Freitag 7. Oktober 2005, 14:47

Joghurt hat geschrieben:Hast du die Datei direkt aus dem ZIP gestartet? Du wirst wohl erstmal das gesamte ZIP entpacken müssen, und dann davon starten.
hm, so dumm bin ich ja nun auch wieder nich ;-)... ne, das .zip habe ich natürlich entpackt...
Tu das Script doch aus C:\Programme\Python\libs woandershin, dort sollte man sowas nicht reintun.
hatte ich ja auch schon woanders, z.b. aufn desktop, da sieht die fehlermeldung aber genauso aus, bloß der pfad is dann n anderer....

Ich wollte das auch grad bei mir testen: grad gemerkt, dass ich Tkinter wegrationalisiert habe
was is tkinter nun schonwieder? brauch ich das dazu, oder was? wie gesagt, ich bin erst seit letzer woche am "lernen"


aber so helfen kann mir scheinbar niemand, oder?
wäre echt super...


mfg
Benutzeravatar
jens
Moderator
Beiträge: 8482
Registriert: Dienstag 10. August 2004, 09:40
Wohnort: duisburg
Kontaktdaten:

Freitag 7. Oktober 2005, 15:14

Also ich hab es auch mal probiert... Ich erhalte den selben Fehler! Die Skripte sind auch etwas seldsam aufgebaut.

Der Fehler liegt wohl darin, das die den Dateinamen parser.py besser nicht hätten nehmen sollen :roll:

Denn in interpreter.py wird nicht deren parser.py importiert, sondern Python's built-in parser.py :!:


Also damit du es zum laufen bekommst, benenne parser.py von denen einfach in parser2.py um. Dann mußt du in der ersten Zeile von interpreter.py folgendes ändern:

Code: Alles auswählen

import parser
ändern in:

Code: Alles auswählen

import parser2 as parser

Ob damit aller 100% läuft kann ich dir nicht sagen...
Du kannst denen vielleicht mal bescheit sagen ;)

CMS in Python: http://www.pylucid.org
GitHub | Open HUB | Xing | Linked in
Bitcoins to: 1JEgSQepxGjdprNedC9tXQWLpS424AL8cd
Pittiplatsch

Freitag 7. Oktober 2005, 15:40

hallo..


hey, vielen dank, so funkt es nun glaube ich, muss nun nur noch diesen s-code machen, und dann mal schauen....

kann es evtl auch daran liegen, das die damals (is ja nun schon jahre her, ne ältere version genommen haben? ich habe jetz die 2.4.2... weis ja nich, inwieweit sich sowas in der zeit verändert?


nochmal vielen dank.... falls nochmal probs auftreten meld ich mich ;-)

mfg Daniel
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Freitag 7. Oktober 2005, 18:46

Pittiplatsch hat geschrieben:kann es evtl auch daran liegen, das die damals (is ja nun schon jahre her, ne ältere version genommen haben? ich habe jetz die 2.4.2... weis ja nich, inwieweit sich sowas in der zeit verändert?
Normalerweise nicht, die Python 2.2 (was ide benutzt haben) hatte auch schon das Modul Parser. Python ändert sich nicht so schnell, alte Programme sollten auch mit neuen Versionen laufen.

Tkinter ist die Bibliothek (=Funktionssammlung) die sie benutzt haben, um die Fenster darzustellen, sie ist normalerweise bei Python mitgeliefert. Da sie aber alt ist und viele Features nur über Umwege möglich sind (davon mal abgesehen dass die Fenster hässlich sind) habe ich sie bei mir gelöscht.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Antworten