Installation von LDAPUserFolder klappt wohl irgendwie nicht

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
zwerg_nr_7
User
Beiträge: 8
Registriert: Mittwoch 19. März 2003, 10:18

Installation von LDAPUserFolder klappt wohl irgendwie nicht

Beitragvon zwerg_nr_7 » Donnerstag 20. März 2003, 11:20

...kann mir jemand weiterhelfen?

Hallo,
ich habe das LDAPUserFolder Modul installiert
( http://www.dataflake.org/software/ldapuserfolder ),
python_ldap habe ich auch installiert
(von http://python-ldap.sourceforge.net/download.shtml )

dann habe ich noch ldapmodule.so in das verzeichnis /<zopepfad>/lib/python/products/LDAPUserFolder kopiert...


mir ist gerade eingefallen das ich ja noch keinen LDAP Server laufen
habe, okay das wäre ein grund dafür das es nicht läuft!
Allerdings dachte ich man könnte es trozdem aus dem PullDownMenue
(Select type to add...) auswählen,
oder sich die API anschauen (welche in der Hilfe zu finden sein soll )!...
Kann mir jemand sagen ob ich bis jetzt etwas gravirendes falsch gemacht
habe? Sollte man es nicht auch ohne LDAPServer installieren (nur nicht nutzen) können!?
Ich wäre für Hilfe wirklich sehr dankbar.

MFG zwerg_nr_7
kasimon
User
Beiträge: 18
Registriert: Freitag 21. März 2003, 20:54
Wohnort: Kiel

Beitragvon kasimon » Samstag 22. März 2003, 00:06

Hi,

auch wenn es dir wohl nicht wirklich hilft: Bei mir läuft das wunderbar. Allerdings konnte ich auch auf die bei Debian Linux beigefügten Pakete zurückgreifen, hatte also mit dem installieren direkt kaum was zu tun :D

Zum installieren brauchst Du tatsächlich keinen LDAP-Server, ohne ist es allerdings ziemlich sinnlos :shock: Vor allem musst Du darauf achten, daß du es richtig konfiguriert, sonst kannst du dich auf dem zope nicht mehr anmelden.

Wenn Du konkrete Fragen hast, kann ich gerne mal einen Blick in unseren Zope-Server werfen, wies da aussieht.
zwerg_nr_7
User
Beiträge: 8
Registriert: Mittwoch 19. März 2003, 10:18

Beitragvon zwerg_nr_7 » Montag 24. März 2003, 09:13

Hi, ja ich weiss ja das es ohne LDAP Server wenig bringt.
Aber ich brauche ja unbedingt auch die API welche in der ZopeHilfe sein soll wenn man es installiert hat!...
und da ich noch nicht genau weiss ob in unserem Unternehmen ein LDAP Server läuft oder vielleicht auch ein X500 Server oder wie auch immer...
(das erfahre ich heute erst - hoffe ich)
hast DU die API dafür?
Könntest Du sie mir evtl. per email schicken, oder hier posten (falls das nicht zu viel ist?)
Kannst Du mir vielleicht auch sagen wo ich was konfigurieren muss ofer wo ich informationen dazu finde (Konfiguration) ?
Ich wäre wirklich dankbar dafür!!!
MFG ZwErG_Nr_7
kasimon
User
Beiträge: 18
Registriert: Freitag 21. März 2003, 20:54
Wohnort: Kiel

Beitragvon kasimon » Montag 24. März 2003, 13:35

zwerg_nr_7 hat geschrieben:Hi, ja ich weiss ja das es ohne LDAP Server wenig bringt.

Das dachte ich mir schon :)
zwerg_nr_7 hat geschrieben:Aber ich brauche ja unbedingt auch die API welche in der ZopeHilfe sein soll wenn man es installiert hat!...
und da ich noch nicht genau weiss ob in unserem Unternehmen ein LDAP Server läuft oder vielleicht auch ein X500 Server oder wie auch immer...
(das erfahre ich heute erst - hoffe ich)
hast DU die API dafür?

Ich bin mir nicht sicher, was Du mit API meinst. Es gibt LDAP-Support für Zope ähnlich z.B. dem Support für Datenbanken wie MySQL etc. Das DebianPaket heisst zope-ldap (was dir wahrscheinlich nicht viel hilft), aber unter http://packages.debian.org/stable/web/zope-ldap.html findest Du auch einen Link auf den originalen Sourcecode. Wenn das richtig installiert ist, soltest Du unter /Control_Panel/Products die Einträge ZLDAPMethods und ZLDAPConnection finden, wenn nicht, dann hast Du ein Problem mit der Installation. Vielleicht hilft dann ein Blick in die Logfiles vom Zope-Start weiter.
Wenn Du eigene Zope-Produkte in Python schreibst, kannst Du auch das in meinem obigen Post erwähnte python-ldap modul verwenden.
zwerg_nr_7 hat geschrieben:Könntest Du sie mir evtl. per email schicken, oder hier posten (falls das nicht zu viel ist?)
Kannst Du mir vielleicht auch sagen wo ich was konfigurieren muss ofer wo ich informationen dazu finde (Konfiguration) ?

Wie gesagt, dafür müsste ich ein bischen genauer wissen, wonach du suchst. Beschreib doch einfach, was du erreichen willst, dann kann ich dir vielleicht eher helfen.
zwerg_nr_7
User
Beiträge: 8
Registriert: Mittwoch 19. März 2003, 10:18

Beitragvon zwerg_nr_7 » Dienstag 25. März 2003, 10:09

Hi,
Danke für die Antworten erstmal!

Also, ich habe eine Webanwendung welche mit Zope realisiert wurde.
Für diese Anwendung gibt es bereits einen Login, der auch Funktioniert.
Dieser soll aber ersetzt werden, und zwar durch einen Login der keine Username und Passwort eingabe erfordert (SingleSignOn). Da man schon bei der Anmeldung von Windows einen Benutzernamen und Passwort angibt, soll 'irgendwie' festgestellt werden wer Du bist...
Also welchen Windows Usernamen Du hast und welcher Domäne Du angehörst.

Wenn diese Daten vorhanden sind (ich weiss immernoch nicht wie ich das anstellen soll) werden Sie mit denen aus einer MS_SQL DB verglichen. Anhand der nun zur verfügung stehenden Daten wirde dem User ein gewisser Benutzerstatus zugewiesen, welcher ihm erlaubt auf gewisse Teile der Anwendung zuzugreifen.

Ich habe gerade gestern erfahren das ich die Benutzerdaten warscheinlichvon einem x500 Server anstatt von einem LDAP Server holen muss....
da ändert sich bestimmt was an der AbfrageSyntax oder so..!?

kurz:
Also diese Aufgabe einen SingleSignOn Mechanismus in diese Webanwendung einzubauen
(so das man sich nur einmal Anmelden muss - und zwar bei der Windows Anmeldung).


BTW. Was ist eigentlich das Python/C API Reference Manual? Das war in meinem Python2.2 Verzeichnis welches ich installiert habe umirgendwie auf einen LDAP Server zuzugreifen...

freundliche Grüße vom 7. zwerg
kasimon
User
Beiträge: 18
Registriert: Freitag 21. März 2003, 20:54
Wohnort: Kiel

Beitragvon kasimon » Dienstag 25. März 2003, 12:37

Puuh...

Das klingt schwierig.

1. X.500-Server können meines Winnens nach nicht dirket von Python (und damit von Zope) angesprochen werden. Ich meine, dass es Gateways von X.500 zu LDAP gibt, bin mir da baer nicht so sicher.

2. Single Sign on. Kurzfassung: Geht nicht. Genauer gesagt: Nicht ohne ganz ganz viel Handarbeit. Es gibt Single-Sign-On-Lösungen wie Kerberos, die möglicherweise auch von Python unterstützt werden können, in dem Bereich bin ich aber nicht fit. Die Frage ist ja, wie Zope durch den Browser des Users an die Windows-Anmeldedaten rankommen soll, umsomehr, als die Verbindung zwischen Zope und dem User-Rechner im Allgemeinen unverschlüsselt abläuft. LDAP wird dir da nicht helfen, der Vorteil eines LDAP-Verzeichnisses zur Benutzerauthentifikation liegt darin, dass die Benutzerdaten inclusive Passwort nur an einer Stelle gespeichert sind. Ein echtes s-s-on ist das aber nicht.

Wilde Idee: Möglicherweise könnte man einen Windows-Client schreiben (ich gehe davon aus, dass deine User unter Windows arbeiten), der (z.B. über xml-rpc) den Zope-Server kontaktet und so am Browser vorbei die Anmeldedaten liefert. Wie das aber im Einzelnen passieren sollte, weiss ich nicht. Für ein ganz einfaches Beispiel könntest Du dir ja mal ansehen, wie der "ExternalEditor"-Kram implementiert ist -- musst Du auf Zope.org nach suchen. Der kontaktet auch "unter der Hand" den Zope-Server von einem lokal laufenden Programm aus. Ansonten wäre ich aber mit selbstgeschrieben Programmen sehr vorsichtig, die Anmeldungsdaten irgendwohin schicken (wenn ich die überhaupt schreiben könnte)! Unter Linux könnte man für sowas möglicherweise ein PAM-Modul coden.

Auch wenn es mich schmerzt das zuzugeben: Das wäre möglicherweise ein Fall für eine der Firmen, die kommerziellen Zope-Support anbieten. Die könnten wahrscheinlich entsprechende Erweiterungen erstellen. Je nachdem, wie wichtig das für euren Betrieb ist...

Das Python/C-Api Handbuch (oder so) hilft einem, wenn man Erweiterungen für Python in C schreiben will.

Trotzdem viel Glück...
zwerg_nr_7
User
Beiträge: 8
Registriert: Mittwoch 19. März 2003, 10:18

...Danke!

Beitragvon zwerg_nr_7 » Mittwoch 26. März 2003, 13:58

Hi,
Danke für die ganzen Informationen,
das hat mir auf jeden fall schonmal weitergeholfen...

also mit den x500 Servern glaube ich gehört zu haben das LDAP ja ursprünglich ein 'Frontend' dafür war, man also einen LDAP Server aufsetzten kann der die Anfragen dann an den x500 Server weiterleitet,...
mal sehn,...

Und was das auslesen den Windows Benutzernamens angeht habe ich auch keine Ahnung wie das möglich sein soll (davon hängt wohl erstmal mein ganzes Projekt ab :( )

Ein Client kommt für dieses Projekt nicht in frage, weil der IE bzw. ein anderer Broswer (welcher auch immer) als Client zum einsatz kommen soll.

mal schaun wie ich meine Abschlussprüfung hinbekomme :-)
(noch bin ich azubi...)

Danke übrigens auch das du so schnell geantwortet hast, ich hätte mich gerne etwas früher bedankt, aber hatte keine Zeit online zu gehen...

mfg
#zwerg_nr_7#
zwerg_nr_7
User
Beiträge: 8
Registriert: Mittwoch 19. März 2003, 10:18

windows Benutzername auslesen geht doch!...

Beitragvon zwerg_nr_7 » Donnerstag 27. März 2003, 10:49

okay,
falls es jemanden interessieren sollte,
es ist möglich den Windows Benutzernamen auszulesen!
Und zwar mit den Produkt / Modul "RemoteUserFolder"
allerdings wird das wohl nicht so oft verwendet oder so, die dokumentation dazu ist etwas dürftig gehalten so weit ich das bis jetzt beurteilen kann...

also schönen Tag noch

#zwerg_nr_7#

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot], de_tom