Fehler mit py2exe und gtk

Programmierung für GNOME und GTK+, GUI-Erstellung mit Glade.
Antworten
Benutzeravatar
Damaskus
Administrator
Beiträge: 919
Registriert: Sonntag 6. März 2005, 20:08
Wohnort: Schwabenländle

Donnerstag 15. September 2005, 14:23

Hallo,
hat mir jemand einen Tipp zu folgendem Problem:

Wenn ich ein py/gtk/glade Programm schreibe es dann mit py2exe kompiliere und dann testen will kommt immer folgende Fehlermeldung:

Code: Alles auswählen

Traceback (most recent call last):
  File "monitor-option.py", line 4, in ?
  File "pygtk.pyc", line 73, in require
AssertionError: required version '2.0' not found on system
mach ich noch irgendwelche Fehler?
Als setup.py verwende ich folgendes script:

Code: Alles auswählen

from distutils.core import setup
import py2exe
 
opts = {
  'py2exe': {
    'includes': 'pango,atk,gobject',
    'dll_excludes': [
      'iconv.dll', 'intl.dll', 'libatk-1.0-0.dll',
      'libgdk_pixbuf-2.0-0.dll', 'libgdk-win32-2.0-0.dll',
      'libglib-2.0-0.dll', 'libgmodule-2.0-0.dll',
      'libgobject-2.0-0.dll', 'libgthread-2.0-0.dll',
      'libgtk-win32-2.0-0.dll', 'libpango-1.0-0.dll',
      'libpangowin32-1.0-0.dll'],
    }
  }

setup(
  name = 'GTKbin',
  description = 'Irgendein GTK Programm',
  version = '0.8.5',
  windows = [
    {'script' : 'monitor-option.py'}
    ],
  options=opts
  )
Antworten