Probleme mit Logging und Windows NT

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
nobs
User
Beiträge: 13
Registriert: Donnerstag 27. Januar 2005, 16:43
Kontaktdaten:

Probleme mit Logging und Windows NT

Beitragvon nobs » Mittwoch 1. Juni 2005, 10:02

Hallo Leute

Folgendes Problem:

Code: Alles auswählen

IOError: [Errno 9] Bad file descriptor
Traceback (most recent call last):
  File "C:\Python24\lib\logging\__init__.py", line 715, in emit
    self.flush()
  File "C:\Python24\lib\logging\__init__.py", line 693, in flush


Das bekomme ich wenn ich mein Script unter WINDOWS NT 4 laufen lasse

passiert in der/den Zeile(n)

Code: Alles auswählen

        for key,value in os.environ.iteritems():
            self.m_logger.debug(key + ' :      ' + value)


Das witzige ist, das er eigentlich ein paar zeilen rausschreibt aber dann
dann kommt der Fehler:
Bsp für eine Ausgabe:
DEBUG:Build_Server:HTTP_REFERER : http://XXXX/buildsrv/
DEBUG:Build_Server:SERVER_SOFTWARE : Apache/2.0.52 (Win32) mod_ssl/2.0.52 OpenSSL/0.9.7e PHP/5.0.3 mod_python/3.1.3 Python/2.3.3
DEBUG:Build_Server:SCRIPT_NAME : /buildsrv/Start_Build.py
DEBUG:Build_Server:SERVER_SIGNATURE : <address>Apache/2.0.52 (Win32) mod_ssl/2.0.52 OpenSSL/0.9.7e PHP/5.0.3 mod_python/3.1.3 Python/2.3.3 Server at XXXXX Port 80</address>

Und dann bricht er ab
weis jemand was ich da falsch mache?
bzw. was ich tun kann, den unter w2k und wxp funktioniert das einwandfrei.

(ps.: Das ist ein Script das von einen python CGI script gestartet wird
und es ist schon seit einigen Monaten auf einen W2k rechner in betrieb
jetzt wollt ich das auf einen WinNT rechner portieren --> Error :( )

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder