Ärger mit apache2

Sockets, TCP/IP, (XML-)RPC und ähnliche Themen gehören in dieses Forum
Antworten
Benutzeravatar
jens
Moderator
Beiträge: 8482
Registriert: Dienstag 10. August 2004, 09:40
Wohnort: duisburg
Kontaktdaten:

Freitag 27. Mai 2005, 14:01

Nun ärgere ich mich schon eine ganze Zeit lang mit apache2 unter ubuntu rum :evil: Ich schaffe es einfach nicht, das ".py" Python-Skripte als cgi ausgeführt werden. Ich bekomme das Skript im Browser immer nur zum runterladen angeboten!
Nur wenn ich es als .cgi abspeichere wird der Interpreter bemüht.

Ich habe schon einige Varianten ausprobiert. Hier mal die Optionen die ich benutz habe:

Code: Alles auswählen

<Files ~ "\.py$">
	Options +ExecCGI
</Files>
AddHandler cgi-script py
AddType cgi-script py
AddType application/x-httpd-cgi .py

AddHandler	python .py
Action		python "/usr/bin/python2

	<Directory "/cgi-bin">
		ForceType cgi-script
		SetHandler cgi-script
		AddHandler cgi-script .py
		AddType cgi-script .py
		Options +ExecCGI
	</Directory>
Allerdings hat keine in irgendeiner Variante fuktioniert.

Kann mir da jemand weiter helfen? Sonst muß ich doch XAMPP nehmen :cry:

CMS in Python: http://www.pylucid.org
GitHub | Open HUB | Xing | Linked in
Bitcoins to: 1JEgSQepxGjdprNedC9tXQWLpS424AL8cd
CM
User
Beiträge: 2464
Registriert: Sonntag 29. August 2004, 19:47
Kontaktdaten:

Freitag 27. Mai 2005, 18:13

Hoi Jens,

Mit .cgi-Suffix läuft alles? Wo ist dann das Problem? Nenne doch einfach Deine Files um. Ist zwar ein seltsames Problem, aber ...

Ansonsten - wenn nicht hier doch jemand eine Antwort weiß - wende Dich doch direkt an die Leute von mod_python (das benutzt Du doch, oder?).

Gruß,
Christian
Benutzeravatar
gerold
Python-Forum Veteran
Beiträge: 5555
Registriert: Samstag 28. Februar 2004, 22:04
Wohnort: Oberhofen im Inntal (Tirol)
Kontaktdaten:

Freitag 27. Mai 2005, 20:42

jens hat geschrieben: Ich schaffe es einfach nicht, das ".py" Python-Skripte als cgi ausgeführt werden. Ich bekomme das Skript im Browser immer nur zum runterladen angeboten!
Hi jens!

Die Datei "hallo.py" habe ich im Ordner /home/gerold/public_html/cgi-bin erstellt:

Code: Alles auswählen

#!/usr/bin/env python

print "Content-Type: text/html"
print
print "<html><head></head><body><p>Seavas</p></body></html"
print
Das habe an das Ende meiner apache2.conf hinzugefügt:

Code: Alles auswählen

<Directory /home/*/public_html/cgi-bin>
   Options +ExecCGI
   AddHandler cgi-script .cgi .py
</Directory>
Apache neu gestartet.
Noch ein

Code: Alles auswählen

chmod +x hallo.py
und schon spuckte mir der Browser nach Eingabe von "http://meinserver.gp/~gerold/cgi-bin/hallo.py" ein "Seavas" aus.

Das mit dem CGI bekommen wir schon hin. Nur keinen voreiligen Fehler (XAMPP) machen ;-)

lg
Gerold
:-)

PS: Kein Ubuntu sondern Debian. Aber da sollte doch kein so großer Unterschied sein.
http://halvar.at | Kleiner Bascom AVR Kurs
Wissen hat eine wunderbare Eigenschaft: Es verdoppelt sich, wenn man es teilt.
Benutzeravatar
jens
Moderator
Beiträge: 8482
Registriert: Dienstag 10. August 2004, 09:40
Wohnort: duisburg
Kontaktdaten:

Samstag 28. Mai 2005, 14:55

Das ist ja sehr merkwürdig :? Jetzt reicht es plötzlich aus, das ich das cgi-bin Verzeichnis nur per ScriptAlias definiere. Alle anderen Konfigurations-Geschichten habe ich auskommentiert... Und ich hätte schwören können, das ich genau diese Konstellation schon einmal erfolglos probiert habe :shock:

Naja, so geht's jedenfalls...

CMS in Python: http://www.pylucid.org
GitHub | Open HUB | Xing | Linked in
Bitcoins to: 1JEgSQepxGjdprNedC9tXQWLpS424AL8cd
Antworten