Installieren und konfigurieren von python,wxpython und boa

Probleme bei der Installation?
Antworten
JonasCleve

Freitag 20. Mai 2005, 14:18

Hi!
Ich habe mir "python-2.4.1.msi", "wxPython2.6-win32-unicode-2.6.0.0-py24.exe", "wxPython2.6-win32-devel-2.6.0.0.tar.gz" und "boa-constructor-0.4.0.win32.exe" heruntergeladen und installiert, bzw entpackt!

Jetzt möchte ich die BoaConstructor-IDE auch öffnen, aber dies funktioniert nicht!

Wie sool das gehen?

Danke für antworten!
JonasCleve
querdenker
User
Beiträge: 424
Registriert: Montag 28. Juli 2003, 16:19
Wohnort: /dev/reality

Freitag 20. Mai 2005, 19:24

ReHi!

erstmal, du brauchst das tar-gz-Package nicht!
Was hilfreich wäre, ist die wxPython-Hilfe.
Des weiteren, gerade unter Win sehr nützlich : win32all
Und da Riaan die letzten Änderungen aus dem CVS noch nicht als Installer fertig hat, solltest du einen kompletten CheckOut des CVS machen.
Alternativ kannst du dich auch mal bei mir melden, dann schicke ich dir den aktuellen Abzug als zippe.

Ansonsten ganz einfach:
Python installieren
wxPython installieren
wxPython-Hilfe installieren
(opt) win32all-Erweiterungen installieren
in das boa-Verzeichnis gehen, boa.pyw (dann startet boa ohne command-shell) starten

hth, querdenker
apollo13
User
Beiträge: 827
Registriert: Samstag 5. Februar 2005, 17:53

Dienstag 2. August 2005, 20:39

ich habe das problem auch und habe es analysiert:

und zwar erstellt wxpython seit 2.4 (python) unter Lib/site-packages/ nen ordner wx-python-ansi(oder unicode) und darin die ordner wx und wxpython. nun zur boa installation: boa installiert sich selbst aber in Lib/site-packages/ und dort in den ordner wxpython unter tools der eigentlich schon von wxpython bestehen sollte. aber wxpython erstellt seit neuerem eben diesen ansi(unicode) ordner und darin erst wxpython. nur wird der ordner ansi automatisch erstellt und als programmpfad wird er nicht angegeben (während der installation, deshalb kann ich im den ordner ansi nicht löschen). und boa lässt sich nicht auf den ansi ordner umlenken da es seine daten aus der registry sucht und meint wxpython hat schon in /Lib/site-packages/ den ordner.

was soll man nun machen das es geht???

meine einzige lösung bis jetzt ist python 2.3 dort gehts, hoffe aber einer von euch weiß wie es für 2.4 geht.

mfg apollo13
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Dienstag 2. August 2005, 21:24

Ich denke das liegt nicht an Python 2.4 sondern an wxPython >= 2.5.3.0, welches MultiVersionInstalls unterstützt.

Weiso kannst du boa nicht aus dem passenden Python File, Boa.py starten? Hast du eine Fehlermeldung?
My god, it's full of CARs! | Leonidasvoice vs Modvoice
apollo13
User
Beiträge: 827
Registriert: Samstag 5. Februar 2005, 17:53

Mittwoch 3. August 2005, 17:48

dann kommt:
Starting Boa Constructor v0.3.1
importing wxPython
Traceback (most recent call last):
File "boa.py", line 194, in ?
from wxPython import wx
File "C:\Python24\lib\site-packages\wx-2.5.3-msw-unicode\wxPython\__init__.py"
, line 10, in ?
import _wx
File "C:\Python24\lib\site-packages\wx-2.5.3-msw-unicode\wxPython\_wx.py", lin
e 3, in ?
from _core import *
File "C:\Python24\lib\site-packages\wx-2.5.3-msw-unicode\wxPython\_core.py", l
ine 15, in ?
import wx._core
File "C:\Python24\wx.py", line 3, in ?
class MyFrame(wx.Frame):
AttributeError: 'module' object has no attribute 'Frame'

achja, ich glaube es ist genau wie in multiversion beschrieben ist.

mfg apollo13
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Mittwoch 3. August 2005, 19:24

Du könntest wxPy 2.6.1.0 installieren, die 2.6er Serie gehört zum stabilen Zweig. Danach könntest du es mit Boa 0.4.4 versuchen. Ich würds ja gerne selbst versuchen, habe aber gerade keine Möglichkeit mir grad eben 10 MB für eine IDE runterzuladen die ich nicht brauche, sorry :cry:
My god, it's full of CARs! | Leonidasvoice vs Modvoice
apollo13_not_logged_in

Mittwoch 3. August 2005, 20:37

danke werde ich versuchen, dass du es runterlädst ist wirklich nicht nötig.

mfg apollo13
Antworten