Nochmals scipy

Probleme bei der Installation?
paul

Nochmals scipy

Beitragvon paul » Donnerstag 5. Mai 2005, 07:58

Hallo nochmal,

mein Python 2.3.5 stürzt immer ab, wenn ich * aus scipy importiere. Ich habe auf einem Windowsrechner Python 2.3.5 und 2.4.1 installiert und möchte eigentlich nur, dass es funktioniert. Also habe ich SciPy_complete-0.3.2.win32P4SSE2-py2.3-num23.5 von scipy .org in den Python ordner(python23) heruntergeladen und ausgeführt. Der Installationsassistent hat dann alles, was zu scipy gehört in den lib\side-packages ordner gespeichert.
Beim importieren kommt immer eine Fehlermeldung und das GUI macht einen Restart.
Unter help und dann modules zeigt er mir aber scipy(packages) u.s.w. an.

Was muss ich anders machen? Muss ich noch was herunterladen? warum finde ich kein scipy, das zu Python2.4.1 passt?
Bitte um hilfe!
Vielen Dank im Voraus.
paul
CM
User
Beiträge: 2464
Registriert: Sonntag 29. August 2004, 19:47
Kontaktdaten:

Beitragvon CM » Donnerstag 5. Mai 2005, 10:19

Hallo Paul,

vorweg: Vermeide bitte Mehrfachpostings wie dieses hier. Du hattest doch schon einen Thread angefangen.

warum finde ich kein scipy, das zu Python2.4.1 passt?

Weil es noch niemand für 2.4 gepackt hat. Wie Du siehst hört die Entwicklung von neuen SciPys irgendwann Ende letzten Jahres auf. Der Grund ist, daß gerade SciPy umgestellt wird. In ein paar Monaten, so das Versprechen, werden wir alle ein generalüberholtes Numpy und Scipy haben. Wenn Du aber den Source unter 2.4 zum Laufen bringen willst, steht dem eigentlich nichts im Wege - vorausgesetzt Du hast alle Libraries und Compiler.

Du hast uns aber immer noch nicht erzählt welches Betriebssystem Du genau benutzt. Jetzt wissen wir irgendein Windows. Aber hast Du geschaut, daß Dein Installer auch für Deinen Prozessor optimiert ist? Du hast insgesamt sechs Installertypen zur Auswahl. Wenn Du Dir nicht sicher bist, versuche doch mal einen Generic-installer.

Und schließlich: Du mußt uns schon sagen, welche Fehlermeldung bei Dir erscheint. Das kann man schließlich nicht erraten.
Muss ich noch was herunterladen?

Das schließlich kann man Dir nur sagen, wenn Du uns sagt, was Du bereits heruntergeladen und installiert hast. Und nochmal: Die Fehlermeldung, die bei Dir erscheint nicht vergessen.

Gruß,
Christian
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Donnerstag 5. Mai 2005, 17:28

Kannst ja mal das SciPy von hier versuchen.
My god, it's full of CARs! | Leonidasvoice vs Modvoice

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot]