StaticBox.SetForegroundColour - Problem

Plattformunabhängige GUIs mit wxWidgets.
HarryH
User
Beiträge: 266
Registriert: Freitag 23. Mai 2003, 09:08
Wohnort: Deutschland

StaticBox.SetForegroundColour - Problem

Beitragvon HarryH » Mittwoch 20. April 2005, 13:10

HAllo,

Ich benutze wxPython 2.5.5.1
Seitdem kann ich bei einer StaticBox keine ForegroundColour mehr vergeben. Es entsteht zwar keine Fehlermeldung, aber eine andere Farbe läßt sich nicht setzen.
Bei wxPython 2.5.3.1 ging es ohne Probleme!

Hat jemand eine Idee an was das liegt?

Danke!
Gruß, Harry
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Mittwoch 20. April 2005, 15:15

Ich würde auf Bugs in wx tippen.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Francesco
User
Beiträge: 824
Registriert: Mittwoch 1. Dezember 2004, 12:35
Wohnort: Upper Austria

Beitragvon Francesco » Mittwoch 20. April 2005, 16:58

Leonidas hat geschrieben:Ich würde auf Bugs in wx tippen.

Sieht so aus. Ich probierte es in wxPython-Demo.
Es scheint, man müsste auch die background colour setzten,
damit die Foreground Colour erscheint.
Beispiel:
self.SetBackgroundColour('light blue')
self.SetForegroundColour('orange')
Du kannst aber auch einen Bug reporten:
http://sourceforge.net/tracker/?group_i ... tid=109863
Ist das wxMSW specific? Dann kannst Du das auch bei der "Category"
angeben.
HarryH
User
Beiträge: 266
Registriert: Freitag 23. Mai 2003, 09:08
Wohnort: Deutschland

re:

Beitragvon HarryH » Montag 2. Mai 2005, 12:25

Hi,

Unter wx.Python 2.6.0 gibt es keine Probleme mehr.
Gruß, Harry

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder