Python 2.4 problem

Probleme bei der Installation?
Antworten
alf

Samstag 12. März 2005, 14:45

Ich habe python2.4 von tgz installiert. Jetzt ist der in /usr/local/... Wie sag ich SuSE Linux
wo der Python ist? Mein System SuSE 9.2 x86_64
Benutzeravatar
Mawilo
User
Beiträge: 446
Registriert: Sonntag 22. Februar 2004, 10:58
Wohnort: Sachsen
Kontaktdaten:

Samstag 12. März 2005, 15:45

Hi alf,

bei mir brauchte ich nichts weiter zu tun (Suse 9.1). Python liegt unter
/usr/local/bin
und das sieht so aus:

Code: Alles auswählen

-rwxr-xr-x  1 root root      96 2004-12-17 22:35 idle
-rwxr-xr-x  1 root root      81 2004-12-17 22:35 pydoc
-rwxr-xr-x  2 root root 3278071 2004-12-17 22:35 python
-rwxr-xr-x  2 root root 3278071 2004-12-17 22:35 python2.4
-rwxr-xr-x  1 root root   18017 2004-12-17 22:35 smtpd.py
-rwxr-xr-x  1 root root   10356 2004-11-27 08:32 tclsh8.4
-rwxr-xr-x  1 root root   10851 2004-11-27 08:35 wish8.4
Geb doch einfach mal > python < in die Konsole ein. Damit sollte sich die Konsole in einen Python-Interpreter verwandeln. Da siehst du, ob auch Python2.4 verwendet wird.

Stephan
alf

Samstag 12. März 2005, 20:25

Bei mir habe ich auch die erste 5 Dateien in /usr/local/bin.

Mein Problem:
Bei ./configure von Superkaramba-0.35
....
checking for Python directory... /usr/local
checking for Python2.3... header /usr/include/python2.3 library no modules no
checking for Python2.2... header no library no modules no
checking for Python2.1... header no library no modules no
...
...
Good -your configure finished. Start make now

Bei eingabe von 'make'
...
...
In Datei, eingefügt von main cpp:5:
karambaapp.h:14:20: Python.h Datei oder Verzeichnis nicht gefunden
In Datei, eingefügt von mei.cpp:19:
karamba.h:8:20 Python.h Datei oder Verzeichnis nicht gefunden
...
dann par mall
karamba_python.h:..: error: .......
...
make: ***[all] Fehler 2

Ich habe RPM für Superkaramba gefunden und mit
rpm -Uvh ........rpm installiert

Superkaramba lauft aber:

Konsole:
Could not find platform independet libraries <prefix>
Consider setting &PYTHONHOME to <prefix>[:<exec_prefix>]

ich habe Wetterstation 'Liquid weather' nicht zum laufen gekrigt,
Superkaramba lädt das Thema, es ist aber unsichtbar,
wenn ich auf der Stelle wo es ist mit rechte Maustaste drücke kommt das menue
leider das Punkt 'Configure theme' ist unaktiv (man kann es nicht auswählen)
Ich kann 'Edit theme' und 'Edit script' auswählen aber das nutz mir nichts

Andere Themen zum anzeigen von temperatur und anderen PC Daten funktionieeren.

Wie und wo muss ich dem System wo ich Python habe?

Bei eingabe von >python<

Python 2.4 (#1, Mar 12 2005, 14:08:48)
[GCC 3.3.4 (pre 3.3.5 20040809)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>
mawe
Python-Forum Veteran
Beiträge: 1209
Registriert: Montag 29. September 2003, 17:18
Wohnort: Purkersdorf (bei Wien [Austria])

Samstag 12. März 2005, 20:51

Hi!

Nur so eine Idee: Könnte es sein, daß Superkaramba Python 2.3 braucht? Oder hast Du das eh auch drauf?

Gruß, mawe
alf

Samstag 12. März 2005, 20:54

Ich habe das (oder war das SuSE) mit installation von SuSE mitinstalliert
alf

Samstag 12. März 2005, 20:57

Als ich Python 2.4 noch nicht hatte habe ich das gleiche Problem gehabt
BlackJack

Samstag 12. März 2005, 23:12

Warum hast Du dann "Python 2.4 problem" als Überschrift gewählt? Offensichtlich hast Du ein Problem mit Superkaramba.

Wenn das Python 2.3 benötigt: Hast Du da auch das python-devel RPM-Paket installiert? Ohne kannst Du nichts dafür übersetzen.
alf

Samstag 12. März 2005, 23:17

Python-devel ist installiert
Antworten