Der berühmte UnicodeDecodeError

Django, Flask, Bottle, WSGI, CGI…
Antworten
BrainLeak
User
Beiträge: 5
Registriert: Dienstag 22. Februar 2005, 13:33

Freitag 25. Februar 2005, 01:08

Hi,

Ich habe hier im Forum schon einiges über den berühmten UnicodeDecodeError gelesen. Jetzt hat es mich auch erwischt.

Folgende Situation:

Es hat hier 2 unterschiedliche Rechner, auf denen Zope installiert ist. Auf einem dritten Rechner ist eine MYSQL-Datenbank. Der Zugriff erfolgt mit dem Produkt ZMySQL Database Connection. Von Rechner 1 funktioniert alles perfekt. Beim Aufruf von Rechner 2 gibt es den Fehler. Auf beiden Rechnern befinden sich die gleichen Dateien (exportiert/importiert).

Ich habe dazu ein paar Tests gemacht, um das Problem einzugrenzen.

Rechner 1:
XML mit Dateien aus Datenbank füllen: OK
HTML-Dateien aus Datenbank füllen: OK
SQL direkt: OK

Rechner 2:
XML mit Dateien aus Datenbank füllen: FEHLER!
HTML-Dateien aus Datenbank füllen: OK
SQL direkt: OK

Jetzt frage ich mich warum es mit der XML-Datei auf dem einem Rechner geht und auf dem anderen nicht. Es kann nach meiner Logik nur ein Einstellungsproblem auf dem Server sein, weil beide XML-Dateien ja identisch sind. Wer weis die Einstellung? Vielen Dank!
Benutzeravatar
jens
Moderator
Beiträge: 8461
Registriert: Dienstag 10. August 2004, 09:40
Wohnort: duisburg
Kontaktdaten:

Freitag 25. Februar 2005, 10:09

Nur so ein Schuss ins Blaue, weil du von UnicodeDecodeError sprichst... Vielleicht sind die locales auf den beiden Rechnern verschieden eingestellt, lass sie dir doch mal anzeigen:

Code: Alles auswählen

import locale
print locale.getdefaultlocale() 
Antworten