gnuplot-py startet nicht aus pyGTK

Programmierung für GNOME und GTK+, GUI-Erstellung mit Glade.
Antworten
sonium
User
Beiträge: 66
Registriert: Mittwoch 27. Oktober 2004, 21:04

Montag 6. Dezember 2004, 16:53

wenn ich versuche gnuplot-py aus pyGTK zu starten, öffnet sich nichts. Der Debug output von gnuplot-py sieht ganz normal aus (außer dass er sich nicht an ein widget umleiten lässt).

Weiß vieleicht jemand Abhilfe?
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Montag 6. Dezember 2004, 17:37

sonium hat geschrieben:wenn ich versuche gnuplot-py aus pyGTK zu starten, öffnet sich nichts. Der Debug output von gnuplot-py sieht ganz normal aus (außer dass er sich nicht an ein widget umleiten lässt).
popen? Dann musst du vermutlich noch stderr umleiten..
sonium hat geschrieben:Weiß vieleicht jemand Abhilfe?
Startet es denn aus Programmen die PyGTK nicht verwenden ohne Probleme? Ich werde mir das mal angucken (pgnuplot habe ich schonmal kompiliert), kann aber für nichts garantieren.
Hast du ein Codebeispiel?
My god, it's full of CARs! | Leonidasvoice vs Modvoice
sonium
User
Beiträge: 66
Registriert: Mittwoch 27. Oktober 2004, 21:04

Montag 6. Dezember 2004, 17:55

ja, bisher gings ohne probleme. Jetzt hab ich das ganze in pyGTK eingebettet. D.h.

g = Gnuplot.Gnuplot(debug=1)

wird auf Knopfdruck ausgeführt.
sonium
User
Beiträge: 66
Registriert: Mittwoch 27. Oktober 2004, 21:04

Dienstag 7. Dezember 2004, 17:13

hat sich erledigt.
der fehler war wohl, dass ich gnuplot aus einem unterthread gestartet hab, und gnuplot deshalb nur so lang lebte, wie der thread.
Antworten