sandbox violation bei easy_install?

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
Antworten
CM
User
Beiträge: 2464
Registriert: Sonntag 29. August 2004, 19:47
Kontaktdaten:

Donnerstag 23. April 2009, 16:49

Hoi,

versuche mich gerade daran ein Paketsetup so hinzubiegen, dass es mit easy_install funktioniert. Wenn ich "easy_install paketname" mit den erforderlichen Rechten aufrufe, wird das Paket korrekt runtergeladen und dann erhalte ich aber

Code: Alles auswählen

error: SandboxViolation: os.open('/home/cm/.matplotlib/tmpmOJGIF', 131266, 384) {}
Etwas Ähnliches wurde mal auf der distutils Mailingliste diskutiert. Das ließ mich denken, dass meine setuptools version zu alt sein könnte, aber:

Code: Alles auswählen

$ python -c "from pkg_resources import require; print require('setuptools')"
ergibt:

Code: Alles auswählen

[setuptools 0.6c9 (/usr/lib/python2.5/site-packages)]
numpy.distutils, wie im verlinkten Thread, nutze ich nicht.
Kann mir jemand sagen, worauf der Fehler hindeutet und was man evtl. tun kann?

Danke,
Christian
CM
User
Beiträge: 2464
Registriert: Sonntag 29. August 2004, 19:47
Kontaktdaten:

Donnerstag 23. April 2009, 17:00

PS Ich sollte vielleicht noch anmerken, dass ein File

Code: Alles auswählen

'/home/cm/.matplotlib/tmpmOJGIF'
bei mir nicht existiert und auch niemals nicht existierte.

Gruß,
Christian
lunar

Donnerstag 23. April 2009, 17:48

Ich kann dir bei deinem eigentlichen Problem nicht helfen, aber sofern du nicht für eine andere Anwendung eine globale Installation dieses Pakets nutzt, würde ich dir raten, lieber mit virtualenv (gibts im Käseladen) eine abgeschottete Entwicklungsumgebung einzurichten. Das hält die globale Python-Installation sauber, vermeidet dadurch Versionskonflikte und erübrigt den Aufruf von easy_install mit Privilegien, da die Umgebung im Nutzerverzeichnis liegt.
CM
User
Beiträge: 2464
Registriert: Sonntag 29. August 2004, 19:47
Kontaktdaten:

Freitag 24. April 2009, 08:59

Danke, das ist ein interessantes Paket. Aber eigentlich möchte ich doch die Probleme mit meinem setup-Skript (bzw. easy_install) in den Griff bekommen. Für zukünftige Entwicklungen / Arbeiten werde ich virtualenv aber im Blick behalten.

Gruß,
Christian
Antworten