Python2.6 + import von PyQt4 == crash

Probleme bei der Installation?
derdon
User
Beiträge: 1316
Registriert: Freitag 24. Oktober 2008, 14:32

Python2.6 + import von PyQt4 == crash

Beitragvon derdon » Mittwoch 8. April 2009, 14:00

Kurz eine Info vorweg: Ich benutze Mac OS X 10.5.6, Python2.5 war schon vorinstalliert. Ich installierte Python2.6 über einen einfachen Installer und achtete beim Installieren von sip und PyQt4 darauf, dass ich beim Aufrufen von configure.py Python2.6 benutze. Bis dahin schien alles korrekt zu laufen. Python2.6 selber läuft ohne Probleme. Wenn ich aber in einer Python-Shell (in der Python2.6 läuft) versuche, etwas aus dem PyQt4-Namespace zu importieren, dann wird folgende Fehlermeldung ausgegeben:

Code: Alles auswählen

Fatal Python error: Interpreter not initialized (version mismatch?)
Abort trap
Außerdem erscheint folgendes Fenster: http://img14.imageshack.us/my.php?image=pythoncrash.tif
derdon
User
Beiträge: 1316
Registriert: Freitag 24. Oktober 2008, 14:32

Beitragvon derdon » Mittwoch 8. April 2009, 18:38

Problem ist gelöst: Ich musste sip noch einmal mit Python2.6 kompilieren, das habe ich vergessen :oops: . Als ich danach PyQt4 mit Python2.6 installierte, lief alles wunderbar!

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder