Mein erstes Python MINI Webprojekt

Stellt hier eure Projekte vor.
Internetseiten, Skripte, und alles andere bzgl. Python.
Benutzeravatar
hendrikS
User
Beiträge: 420
Registriert: Mittwoch 24. Dezember 2008, 22:44
Wohnort: Leipzig

Dienstag 10. Februar 2009, 00:39

Ich habe jetzt mal mein erstes kleines Mini Webprojekt soweit fertiggestellt, daß man zumindest mal was vernünftiges sehen kann.
Nichts Aufregendes und wesentlich neues. Nur ein kleiner Kalender.
Wen's interessiert einfach mal hier klicken.

Die Darstellung des Kalenders ist nicht im Konquerer möglich.

http://www.jipsong.de/cgi-bin/webcal.py

Der Rest der Website folgt dann in den kommenden Wochen. Ich plane vielleicht das ganze noch ein bisschen zu erweitern.
- Printing View
- SVG/PDF export
- WSGI interface

Abgesehen davon habe ich mich nicht zuletzt wegen der Kommentare im Wiki und was ich neulich so alles gelernt habe über Webprogrammierung für SYSPROVIDE entschieden. Bis jetzt alles OK.[/b]
Zuletzt geändert von hendrikS am Freitag 13. Februar 2009, 23:29, insgesamt 2-mal geändert.
Dauerbaustelle
User
Beiträge: 996
Registriert: Mittwoch 9. Januar 2008, 13:48

Dienstag 10. Februar 2009, 11:39

Die Darstellung des Kalenders ist doppelplusungut, weil du keine Tabelle verwendest, was zur Folge hat, dass die Darstellung in verschiedenen Browsern (verschiedene Fonts/Schriftgrößen) anders aussieht (falsch aussieht).

Was bringt die Region? Wir haben glaube ich überall in Deutschland die gleichen Kalendertage O__o
Benutzeravatar
hendrikS
User
Beiträge: 420
Registriert: Mittwoch 24. Dezember 2008, 22:44
Wohnort: Leipzig

Dienstag 10. Februar 2009, 11:48

@Dauerbaustelle

Danke fuer den Kommentar,

eine Tabellendarstellung ähnlich dem HTMLCalendar mache ich vielleicht noch. Getestet und entwickelt habe ich das mit Internet Explorer. Mich wundert ein bisschen, das es so verschieden ist. Pygments verwendet ein ähnliches Konzept.
Ich nehme die OS und Browserspezifischen Dinge mal auf meine Todo Liste.

Was die Feiertage angeht irrst Du gewaltig. Die sind in fast jedem Bundesland verschieden.
Dauerbaustelle
User
Beiträge: 996
Registriert: Mittwoch 9. Januar 2008, 13:48

Dienstag 10. Februar 2009, 12:08

Achso, Feiertage.

Ja, das mit Pygments ist etwas anders, weil dort eine Nichtproportiale Font eingesetzt wird...
Benutzeravatar
hendrikS
User
Beiträge: 420
Registriert: Mittwoch 24. Dezember 2008, 22:44
Wohnort: Leipzig

Dienstag 10. Februar 2009, 12:15

Ich kann das Formatierungsproblem im Moment nicht checken.
Ich hatte eigentlich Courier New angegeben, um sicherzustellen, dass es ordentlich dargestellt wird.
Ich denke es ist nur eine Frage des Style sheets. Guck ich mir am Wochenende mal an.
Dauerbaustelle
User
Beiträge: 996
Registriert: Mittwoch 9. Januar 2008, 13:48

Dienstag 10. Februar 2009, 14:15

Du hast überhaupt keine Schriftart angegeben.
Benutzeravatar
hendrikS
User
Beiträge: 420
Registriert: Mittwoch 24. Dezember 2008, 22:44
Wohnort: Leipzig

Dienstag 10. Februar 2009, 15:18

Browserunabhängig zu entwickeln scheint offenbar ein MEGA problem zu sein. Eigentlich wuerde ich an der Stelle mal eine Diskussion anregen ob es Strategien gibt, wie man hier am besten vorgeht.
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Dienstag 10. Februar 2009, 15:23

hendrikS hat geschrieben:Browserunabhängig zu entwickeln scheint offenbar ein MEGA problem zu sein.
Zwischen Firefox, Opera und WebKit-basierten ist das idR. kein Problem. Dumm nur wenn man IE unterstützen muss. Meine Lösung ist jetzt ganz einfach: XHTML 1.1 als XML ausliefern lassen, das rendert IE dann nichtmal und damit habe ich das Problem vom Kopf während die Seiten mit besseren Browserengines passabel aussehen.

Du willst gar nicht wissen wie viel Zeit immer draufgeht, bis die Seite dann in IE halbwegs sinnvoll aussehen.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Dauerbaustelle
User
Beiträge: 996
Registriert: Mittwoch 9. Januar 2008, 13:48

Dienstag 10. Februar 2009, 16:13

Das Problem liegt hier allerdings an dir, du versuchst Abstände zwischen zwei Zahlen/Buchstaben mittels WHITESPACE zu lösen. Dumm nur, dass HTML Whitespace ignoriert... benutze Tabellen oder CSS-Tabellen!
Benutzeravatar
hendrikS
User
Beiträge: 420
Registriert: Mittwoch 24. Dezember 2008, 22:44
Wohnort: Leipzig

Dienstag 10. Februar 2009, 16:21

Ja, bis zum Wochenende kann ich nichts machen.

Kurzfristig werde ich mir auf jeden Fall andere Browser einspielen. Ebenso eine VM um mit Linux zu testen.

Ob es gleich eine Tabellenlösung wird, weiss ich noch nicht.
Es muss eigentlich auch so gehen.

Leonidas' Kommentare muss ich mir auch mal durch den Kopf gehen lassen.
tordmor
User
Beiträge: 100
Registriert: Donnerstag 20. November 2008, 10:29
Wohnort: Stuttgart

Mittwoch 11. Februar 2009, 09:42

hendrikS hat geschrieben:Browserunabhängig zu entwickeln scheint offenbar ein MEGA problem zu sein.
Nö, wenn man fürs Layout nicht HTML nimmt, sondern CSS wie es gedacht ist und nicht px sondern durchgehend mm als Einheit, dann gibt es nicht so viele Schwierigkeiten.
http://www.felix-benner.com
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Mittwoch 11. Februar 2009, 09:49

Statt ``mm``würde ich eher zu ``em`` raten.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Benutzeravatar
hendrikS
User
Beiträge: 420
Registriert: Mittwoch 24. Dezember 2008, 22:44
Wohnort: Leipzig

Mittwoch 11. Februar 2009, 15:54

Ich habe offline mal n'bischen an der Formatierung korrigiert. Der PRE Teil wird auf jeden Fall komplett per CSS formatiert. Das sollte das Problem lösen. Es gibt eine FONT-FAMILY Anweisung monospace, die sicherstellen sollte, dass egal welcher Browser oder OS in jedem Fall eine monospaced Schriftart verwendet wird.

IE, Firefox und Opera konnte ich schon mal synchronisieren. Ich kann aber nicht bestätigen, dass IE die meisten Probleme macht. Es haben alle ihre Macken. Vielleicht probiere ich noch Chrome.
Dauerbaustelle
User
Beiträge: 996
Registriert: Mittwoch 9. Januar 2008, 13:48

Mittwoch 11. Februar 2009, 15:55

Die Darstellung ist bei mir halt immer noch voller Mist...

http://ubuntu-pics.de/bild/9600/shot_5VW84J.png
Benutzeravatar
hendrikS
User
Beiträge: 420
Registriert: Mittwoch 24. Dezember 2008, 22:44
Wohnort: Leipzig

Mittwoch 11. Februar 2009, 17:44

Ich habe bisher nur offline was gemacht. Die updates kann ich erst am Wochenende einstellen.
Wenn ich denn sicher bin das im Griff zu haben, werde ich es hier in diesem Thread ankuendigen.
Antworten