SPE 0.8.4 Installation

Probleme bei der Installation?
Antworten
sarstein
User
Beiträge: 6
Registriert: Donnerstag 5. Februar 2009, 16:29

Donnerstag 5. Februar 2009, 17:05

Hallo Kollegen

Als Python Jungfuchs habe ich Startschwierigkeiten. Die neu installierte IDE "SPE" läßt sich nicht aufrufen.

Habe das zip-file "SPE-0.8.4.c-wx2.6.1.0-no_setup" von Stanis homepage

http://pythonide.blogspot.com/search/label/spe

heruntergeladen, und den nach dem Entpacken entstandenen Ordner "_spe" in das directory "*\Python26\Lib\site-packages\_spe" kopiert.
Laut homepage soll sich direkt aus dem Verzeichnis "_spe" die IDE mit "python SPE.py" starten lassen. Passiert aber nichts. Auch aus der DOS shell (Eingabeaufforderung) aus dem "_spe" Verzeichnis ist das nicht möglich. Seltsam ist, daß SPE ohne Installations-SW geliefert wird.

Die bei Python integrierte IDLE IDE läuft.

System:
HP 6325 Notebook, XP SP3, 2,4GHz Athlon, 2GB RAM

Momentan dreh ich mich im Kreis. Bitte wer hat eine Idee!

cu
Chris
Benutzeravatar
cofi
Moderator
Beiträge: 4432
Registriert: Sonntag 30. März 2008, 04:16
Wohnort: RGFybXN0YWR0

Donnerstag 5. Februar 2009, 17:08

Die Fehlermeldung beim Starten aus der Konsole wäre hilfreich.
Da meine Kristallkugel grad nich will, würde ich mal auf ein fehlendes wxPython tippen ;)
sarstein
User
Beiträge: 6
Registriert: Donnerstag 5. Februar 2009, 16:29

Donnerstag 5. Februar 2009, 17:33

Hallo cofi

schon mal danksche.

aus der Konsole)
bei Eingabe von "spe.py" kommt das Fenster "Öffnen mit", klickt man auf python, so wird kurz ein ein Fenster geöffnet und sofort wieder geschlossen. In der kurzen Zeit ist aber nicht lesbar was da drin steht.

Bei der Eingabe von "python spe.py" kommt die Meldung, dass python nicht gefunden wurde oder falsch geschrieben ist.

wxPython)
das hab ich natürlich nicht mit installiert. Auf Stanis webpage hab ich davon aber auch nichts gelesen. Spielt dabei auch die Version eine Rolle?

Ich schau mal wo ich das find'.

cu
Chris
sarstein
User
Beiträge: 6
Registriert: Donnerstag 5. Februar 2009, 16:29

Donnerstag 5. Februar 2009, 17:42

Hi cofi

wxPython2.8-win32-ansi-2.8.9.1-py26 als exe auf SourceForge.net gefunden.
Versuch das mal zu installieren.

Chris
sarstein
User
Beiträge: 6
Registriert: Donnerstag 5. Februar 2009, 16:29

Donnerstag 5. Februar 2009, 17:56

Hi cofi

hast ne gute Kristallkugel ;-), wo kriegt man die?

wxPython in site-packages installiert und schon läuft's.

Vielen, herzlichen Dank für die prompte Hilfe.

Chris
Benutzeravatar
cofi
Moderator
Beiträge: 4432
Registriert: Sonntag 30. März 2008, 04:16
Wohnort: RGFybXN0YWR0

Donnerstag 5. Februar 2009, 18:05

Naja die wollte ja nicht ;) Da SPE auf wxPython aufsetzt und wohl auf einfache Installation Wert legt lag es nahe, dass da der Fehler ist ;)

Apropos von Konsole heisst: Eingabeaufforderung -> `python datei.py'
Gegebenenfalls mit Pfad, wenn Windows da quengelig is ;)
sarstein
User
Beiträge: 6
Registriert: Donnerstag 5. Februar 2009, 16:29

Donnerstag 5. Februar 2009, 18:28

Als Python greenhorn sind mir diese Zusammenhänge -und wahrscheinlich noch vieles andere mehr- natürlich noch unbekannt. Ist zwar derzeit noch "Hobby", aber Python scheint mir vielseitig einsetzbar, sodaß die Arbeit sich hoffentlich lohnt.
Das nächste wird wohl von MS weg ein Schwenk auf Debian oder Ubuntu werden, da Cygwin zwar hilfreich, aber halt auch mit Einschränkungen verbunden ist.

Die Konsolenhandhabung ist mir einigermaßen klar, damit habe ich reichlich rumgespielt.

Soviel dazu. Gruß Chris
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Donnerstag 5. Februar 2009, 19:23

Generell lesenswert dazu: [wiki]FAQ[/wiki].
sarstein
User
Beiträge: 6
Registriert: Donnerstag 5. Februar 2009, 16:29

Donnerstag 5. Februar 2009, 19:33

Danke, vorbildliche Unterstützung hier!
Antworten