python2.6, Ubuntu und Tkinter

Probleme bei der Installation?
Benutzeravatar
HorstJENS
User
Beiträge: 123
Registriert: Donnerstag 9. Februar 2006, 21:41
Wohnort: Wien, Österreich
Kontaktdaten:

python2.6, Ubuntu und Tkinter

Beitragvon HorstJENS » Montag 13. Oktober 2008, 09:17

Hi,

bräuchte Tipps von jemanden der python 2.6 inklusive Tkinter unter Ubuntu8.04 erfolgreich installiert hat.

Python 2.6 downloaden und kompilieren ging ganz gut, python2.6 liegt jetzt unter /usr/local/lib/python2.6

pygame 1.8.1 installieren (selber kompiliert) ging auch ganz gut, musste lediglich die Berechtigung bei einem Font nachbesseren

mein Problem:

Tkinter funktioniert nicht. Ich bekomme diese Fehlermeldung:
[code=]
>>> import Tkinter
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/usr/local/lib/python2.6/lib-tk/Tkinter.py", line 39, in <module>
import _tkinter # If this fails your Python may not be configured for Tk
ImportError: No module named _tkinter[/code]


kann mir jemand weiterhelfen ?
BlackJack

Beitragvon BlackJack » Montag 13. Oktober 2008, 09:40

Hast Du vor dem Kompilieren auch das entsprechende `Tk?.?-dev`-Paket installiert?
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Montag 13. Oktober 2008, 12:32

Wenn dich die genauen Dependencies interessieren, solltest du die .dsc-Datei von Python 2.5 ansehen, dort steht das in den Build-Depends.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Benutzeravatar
HorstJENS
User
Beiträge: 123
Registriert: Donnerstag 9. Februar 2006, 21:41
Wohnort: Wien, Österreich
Kontaktdaten:

danke

Beitragvon HorstJENS » Montag 13. Oktober 2008, 20:53

Danke, es war das fehlende Tk*.dev - Paket.

Jetzt funktioniert alles :-)
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Montag 13. Oktober 2008, 23:44

Wundert es eigentlich außer mir niemanden, dass Python auf Debian/Ubuntu ein Build-Dependancy auf die libbluetooth hat? Mir ist nicht bekannt, dass Python irgendwas zum Thema Bluetooth in der Stdlib enthält.
My god, it's full of CARs! | Leonidasvoice vs Modvoice

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder