Debian Etch - Python2.4 - Installation von Pocoo

Probleme bei der Installation?
mad max
User
Beiträge: 2
Registriert: Mittwoch 24. September 2008, 22:38

Debian Etch - Python2.4 - Installation von Pocoo

Beitragvon mad max » Mittwoch 24. September 2008, 22:50

Hallo ich versuche jetzt seit 3 Tagen vergebens Pocoo zu installieren. Ich hoffe hier kann mir jemand weiterhelfen.

Ich bin genau nach dieser Anleitung gegangen:

1================
2 Installing Pocoo
3 ================
4
5
6 A note first
7 ============
8
9 If you have any troubles with installing or find this guide to be
10 too sketchy, please tell us in #pocoo on irc.freenode.net or open
11 a ticket at http://trac.pocoo.org/newticket -- Thanks.
12
13
14 Installing Pocoo
15 ================
16
17 *Note:* If you installed from the Pocoo Python egg, werkzeug, jinja,
18 SQLAlchemy and simplejson will already have been installed as a
19 dependency. You'll then only have to install the database adapter,
20 then you can proceed with "Creating a Pocoo instance"
21
22 You'll need at least Python 2.4 to use Pocoo.
23
24 To install and use Pocoo, you will need to:
25

//Dann die Abhängigkeiten installieren

26 * install the dependencies:
27
28 - *Werkzeug* version >= 0.1 from http://werkzeug.pocoo.org
29 - *Jinja* version >= 1.2 from http:///jinja.pocoo.org
30 - *SQLAlchemy* version >= 0.3.0 from http://www.sqlalchemy.org
31 - *simplejson* from http://undefined.org/python
32 - *Pygments* version >= 0.6 from http://pygments.org
33 if you want to use the ``highlight`` package for source code
34 highlighting.
35
36 - a database adapter, such as
37 *pysqlite* version 2 from http://pysqlite.org or
38 *MySQLdb* from http://sourceforge.net/projects/mysql-python or //Denke mal das ist für uns wichtig da wir ja MySQL betreiben
39 *psycopg2* from http://www.initd.org/tracker/psycopg.
40
41 You can install most of them with ``easy_install``.
42
43 * install the Pocoo modules: either install it into the site-packages using
44 ``python setup.py install``, or put it into some other directory
45 where your webserver process can read it.
46
47
48 Creating a Pocoo instance
49 =========================


50
51 * create an empty directory, e.g. ``/path/to/instance``
52 * initialize the instance with::
53



54 python /path/to/pocoo/management.py createinstance /path/to/instance
55
56 * configure the instance by editing the newly created ``pocoo.conf``.
57 Especially the ``database`` settings will be interesting.
58
59


danach denn POCOO_ROOT=/path/to/instance python /path/to/pocoo/scripts/make_testdata.py

60 Creating test data
61 ==================
62
63 In order to test Pocoo, you'll have to create your selected database
64 (in case of SQLite, the database file will be created automatically).
65
66 Then, you can insert test data into the database by running::
67
68 POCOO_ROOT=/path/to/instance python /path/to/pocoo/scripts/make_testdata.py
69
70 This will create some bogus users, forums and posts.
71



Jedoch erhalte ich bei diesem Teil "POCOO_ROOT=/path/to/instance python /path/to/pocoo/scripts/make_testdata.py"eine Fehlermeldung!!


Dieser Fehler wird mir angezeigt:

server1:~# POCOO_ROOT=/home/pocoo python /usr/lib/python2.4/site-packages/Pocoo-0.1.5/scripts/make_testdata.py
Traceback (most recent call last):
File "/usr/lib/python2.4/site-packages/Pocoo-0.1.5/scripts/make_testdata.py", line 154, in ?
from pocoo.context import ApplicationContext
File "/usr/lib/python2.4/site-packages/Pocoo-0.1.5-py2.4.egg/pocoo/context.py", line 39, in ?
from jinja.lib import stdlib
ImportError: No module named lib

Irgenwie scheint da noch was zu fehlen nur was??


Für jede Hilfe wäre ich dankbar
:D
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Mittwoch 24. September 2008, 22:59

Pocoo ist tot und wird nicht mehr fortgeführt, das zu installieren ist sinnlos, da die Entwickler nie eine allgemein brauchbares Release rausgebracht haben.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
mad max
User
Beiträge: 2
Registriert: Mittwoch 24. September 2008, 22:38

Beitragvon mad max » Mittwoch 24. September 2008, 23:12

Ok dann kann ich dieses Projekt wohl abbrechen. War für einen Freund von mir, der mal eine Forensoftware gschrieben in Python probieren wollte. Gibt es denn noch andere Forensoftware auf Python Basis???
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Mittwoch 24. September 2008, 23:16

mad max hat geschrieben:Gibt es denn noch andere Forensoftware auf Python Basis???

Inyoka, Palaver. Aber momentan gibt es nicht so die Wahl, mal sehen wie das aussieht wenn Inyoka tatsächlich *released* wird.
My god, it's full of CARs! | Leonidasvoice vs Modvoice

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder