.pyc funktionieren nicht mehr nach Upgrade

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
Antworten
smacgyver
User
Beiträge: 2
Registriert: Dienstag 5. August 2008, 13:57

Dienstag 5. August 2008, 14:04

Hallo Leute,

ich möchte kompilierte Python-Dateien von Version 1.6 auf Version 2.5 ausführen. Leider ohne Erfolg. Keine Fehlermeldung, nur eine leere Seite. Gibt's da irgendwelche Abhängikeiten bzw. muss ich .py Datein neu-kompilieren damit das funktioniert?

Für eine Antwort wär ich sehr dankbar.
Mad-Marty
User
Beiträge: 317
Registriert: Mittwoch 18. Januar 2006, 19:46

Dienstag 5. August 2008, 15:23

Hallo,

nein das geht nicht, pyc's und pyo's sind versionsabhängig
smacgyver
User
Beiträge: 2
Registriert: Dienstag 5. August 2008, 13:57

Dienstag 5. August 2008, 16:00

Thx!! Dacht ich mir schon ....
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Montag 11. August 2008, 12:42

Mad-Marty hat geschrieben:nein das geht nicht, pyc's und pyo's sind versionsabhängig
Ja, soweit ich mich erinnere nutzen sie das Marshall-Protokoll und das ist nur in Major-Releases (2.5.x oder 2.4.x oder 2.3.x, etc) kompatibel, in späteren Versionen wird nicht garantiert dass es kompatibel bleibt. Noch dazu ist Python 1.6 schon sehr, sehr alt.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Antworten