Python falsch vorinstalliert

Probleme bei der Installation?
dobberph
User
Beiträge: 23
Registriert: Mittwoch 8. November 2006, 09:36

Python falsch vorinstalliert

Beitragvon dobberph » Montag 21. Juli 2008, 15:12

Hi ihr,

ich hab noch ein weiteres Problem:
Python ist bei mir anscheinend falsch vorinstalliert. Wenn ich irgendwelche Installationen durchführen will, kommt immer wieder die Fehlermeldung:
[code=]error: invalid Python installation: unable to open /usr/lib/python2.3/config/Makefile (No such file or directory)[/code]

Das Verzeichnis "config" existiert gar nicht.

Danke und mfg,
DerTobi
Das einzige, was leicht ist, ist verzweifeln...
Benutzeravatar
cofi
Moderator
Beiträge: 4432
Registriert: Sonntag 30. März 2008, 04:16
Wohnort: RGFybXN0YWR0

Beitragvon cofi » Montag 21. Juli 2008, 15:18

Drei Dinge wären hier noch interessant:

- Bei was kommt das genau? "irgendwelche Installationen" ist nicht wirklich sehr genau ...

- Welche Python-Version ist denn installiert? ``python --version''

- Welche Distribution verwendest du denn?
BlackJack

Beitragvon BlackJack » Montag 21. Juli 2008, 15:24

Und ist das Entwicklerpaket installiert? Bei den meisten Distributionen endet der Paketname mit `dev` oder `devel`. Ich glaube SuSE verwendet letztere Konvention.
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Montag 21. Juli 2008, 16:25

cofi hat geschrieben:- Welche Distribution verwendest du denn?

Zumindest das ist aus dem anderen Thread bekannt, es ist Debian Sarge; somit wäre das entsprechende Entwicklungspaket also ``python2.3-dev``.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
dobberph
User
Beiträge: 23
Registriert: Mittwoch 8. November 2006, 09:36

Beitragvon dobberph » Montag 21. Juli 2008, 16:43

[code=]vs169126:~# python -V
Python 2.3.5
[/code]

Sarge

Ich wollte gerade z.B. mechanize (bzw. erstmal easy_install) installieren.
[code=]vs169126:/var/www# python ez_setup.py
Downloading http://pypi.python.org/packages/2.3/s/setuptools/setuptools-0.6c8-py2.3.egg
error: invalid Python installation: unable to open /usr/lib/python2.3/config/Makefile (No such file or directory)[/code]

Hoffe das reicht als Infos ;D
[/code]
Das einzige, was leicht ist, ist verzweifeln...
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Montag 21. Juli 2008, 16:57

Na dann musst du wohl python2.3-dev installieren.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
dobberph
User
Beiträge: 23
Registriert: Mittwoch 8. November 2006, 09:36

Beitragvon dobberph » Montag 21. Juli 2008, 20:40

AH, ok danke

hat funktioniert.

Mfg,
DerTobi
Das einzige, was leicht ist, ist verzweifeln...

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder