zope starten

Django, Flask, Bottle, WSGI, CGI…
Pamtoffel
User
Beiträge: 7
Registriert: Donnerstag 7. November 2002, 12:29

zope starten

Beitragvon Pamtoffel » Freitag 8. November 2002, 11:32

Hallo zusammen,

habe ein kleines Problem mit Zope. Habe Zope 2.6.0 unter SuSeLinux 8.0 installiert (nicht von der Distributions-CD). Nun starte ich den Server über einen SSH-Client mit dem Befehl "./start -u root". Funktioniert auch wunderbar, allein - wenn ich den SSH-Clienent schliesse oder mich auslogge wird Zope wieder beendet. Hat jemand 'ne Idee woran das liegen könnte?

Gruss und Dank
Pamtoffel
Benutzeravatar
Beyond
User
Beiträge: 227
Registriert: Freitag 6. September 2002, 19:06
Kontaktdaten:

Beitragvon Beyond » Montag 23. Dezember 2002, 21:56

Es wird vmtl. ein Term-Signal an Zope geschickt. Probier doch mal meinen Zope-Daemon.

Eine alte Version (ich bastel mehr oder minder fleißig an einer neuen) gibt's z.B. unter

http://gd.tuwien.ac.at/opsys/linux/sour ... eDaemon.py

cu beyond
Benutzeravatar
hans
User
Beiträge: 728
Registriert: Sonntag 22. September 2002, 08:32
Wohnort: Sauerland
Kontaktdaten:

Beitragvon hans » Montag 23. Dezember 2002, 22:49

Code: Alles auswählen

nohup ./start -u root 2>1&
sollte auch gehen. Sollten Terminalausgaben erfolgen, so stehen diese in nohup.out

Kannst du das nicht als Deamon starten? gibt es kein /etc/rc.d/zope ? Wenn's das gibt, kannst du das in der Regel mit /etc/rc.d/zope start starten. Lass mal hören, was du rausbekommen hast.

Hans

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder