EPYdoc Beispiel läuft nicht

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
Secki
User
Beiträge: 5
Registriert: Donnerstag 10. Juli 2008, 11:00

EPYdoc Beispiel läuft nicht

Beitragvon Secki » Donnerstag 10. Juli 2008, 11:11

Hallo zusammen,

ich wollte mein Programm mit Epydoc dokumentieren. Dazu hab ich mir das Beispiel von http://epydoc.sourceforge.net/configfile.html geholt und auf meine Bedürfnisse eingestellt. Allerdings weiß ich nicht, wie ich aus diesm Beispiel jetzt die Dokumentation generieren lassen kann. Wenn ich es als Skript ausführe, bekomme ich schon in der 2. Zeile bei modules: einen Fehler. Er erkennt hier den Doppelpunkt als Fehler??
Kann mir da jemand helfen?
Danke im Vorraus

Grüße
Zap
User
Beiträge: 533
Registriert: Freitag 13. Oktober 2006, 10:56

Beitragvon Zap » Donnerstag 10. Juli 2008, 11:44

Was du da hast ist ein Configfile und du must dies an Epidoc übergeben
In diesem Configfile ist halt festgelegt welche Sourcen Analysiert werden soll.
[code=]python c:\python25\Scripts\epydoc.py --conf=epydoc_export.cfg[/code]
Secki
User
Beiträge: 5
Registriert: Donnerstag 10. Juli 2008, 11:00

Beitragvon Secki » Donnerstag 10. Juli 2008, 11:56

Danke, das hilft mir schonmal weiter, ich versteh nur noch nicht so ganz dein Beispiel. Wie und wo übergebe ich denn das Configfile?
Zap
User
Beiträge: 533
Registriert: Freitag 13. Oktober 2006, 10:56

Beitragvon Zap » Donnerstag 10. Juli 2008, 12:12

Mh... :?

Also:

erstelle eine kleine Datei namens "test.cfg" mit folgendem Inhalt:
[code=][epydoc]
name: OS API
modules: os
target: os_apidocs[/code]

Nun startest du das epydoc.py Skript (das sich unter MeinPython/Scripts befindet). Diesem übergibst du beim Start den Parameter --config=test.cfg

Beispiel bei mir:

Code: Alles auswählen

C:\>python c:\Python25\Scripts\epydoc.py --conf=test.cfg


Als Ergebnis solltest du nun einen Ordner "os_apidocs" vorfinden in dem die API des OS Modules dokumentiert ist.
Secki
User
Beiträge: 5
Registriert: Donnerstag 10. Juli 2008, 11:00

Beitragvon Secki » Donnerstag 10. Juli 2008, 13:03

Alles klar, jetzt funktionierts einwandfrei! Danke für die schnelle Hilfe.
Bin schon ein Kind der Windowsgeneration, deshalb hab ich beim Aufruf einer Datei + Übergeben einer Datei nicht an DOS gedacht. Eine frage bleibt aber: Wieso die Umwandlung in ein cfg file? Würd das auch noch anders funktionieren? :?:

Wer ist online?

Mitglieder in diesem Forum: __deets__, Kniffte, pixewakb