[gelöst] self."%s" funktioniert nicht

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
Chrispy
User
Beiträge: 37
Registriert: Montag 10. September 2007, 22:43

[gelöst] self."%s" funktioniert nicht

Beitragvon Chrispy » Samstag 5. Juli 2008, 19:40

Also ich wollte gerade ein Programm vereinfachen, indem ich verschiedene Funktionen bereitstelle. Dort wo diese Funktionen vorher vollständig gecoded waren, sollen sie jetzt nur noch mit den jeweiligen parametern aufgerufen werden, aber folgendes funktioniert nicht:

Code: Alles auswählen

def ini_widget(self, widget):
      self."%s" % widget = self.wTree.get_widget("%s" % widget)


(Invalid Syntax)

weiss jemand weiter?
Zuletzt geändert von Chrispy am Sonntag 6. Juli 2008, 06:37, insgesamt 1-mal geändert.
DasIch
User
Beiträge: 2423
Registriert: Montag 19. Mai 2008, 04:21
Wohnort: Berlin

Beitragvon DasIch » Samstag 5. Juli 2008, 19:44

self.irgendeinstring :shock:
Benutzeravatar
mitsuhiko
User
Beiträge: 1790
Registriert: Donnerstag 28. Oktober 2004, 16:33
Wohnort: Graz, Steiermark - Österreich
Kontaktdaten:

Beitragvon mitsuhiko » Samstag 5. Juli 2008, 19:57

setattr(self, name, objekt)
TUFKAB – the user formerly known as blackbird
Chrispy
User
Beiträge: 37
Registriert: Montag 10. September 2007, 22:43

Beitragvon Chrispy » Sonntag 6. Juli 2008, 06:36

vielen dank! :D

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder