Problem mit Werkzeug...

Sockets, TCP/IP, (XML-)RPC und ähnliche Themen gehören in dieses Forum
nemomuk
User
Beiträge: 862
Registriert: Dienstag 6. November 2007, 21:49

Problem mit Werkzeug...

Beitragvon nemomuk » Freitag 2. Mai 2008, 19:29

Hallo,

ich bin gerade dabei mich in Werkzeug einzuarbeiten... (kapiere gerade nicht alles...), schaffe es aber nicht die Shell zu starten...

Bekomme folgenden Fehler, wenn ich "python manage.py shell" ausführe:

[code=]Traceback (most recent call last):
File "manage.py", line 17, in ?
script.run()
File "/usr/lib/python2.4/site-packages/Werkzeug-0.2-py2.4.egg/werkzeug/script.py", line 166, in run
return func(**arguments)
File "/usr/lib/python2.4/site-packages/Werkzeug-0.2-py2.4.egg/werkzeug/script.py", line 246, in action
namespace = init_func()
File "manage.py", line 9, in make_shell
from shorty import models, utils
File "/var/www/vhosts/XXX/httpdocs/werkzeug/shorty/utils.py", line 2, in ?
from sqlalchemy.orm import create_session, scoped_session
ImportError: cannot import name scoped_session[/code]

Was ist da falsch?

Danke!
Benutzeravatar
mitsuhiko
User
Beiträge: 1790
Registriert: Donnerstag 28. Oktober 2004, 16:33
Wohnort: Graz, Steiermark - Österreich
Kontaktdaten:

Beitragvon mitsuhiko » Freitag 2. Mai 2008, 21:12

Zu alte SQLAlchemy version.
TUFKAB – the user formerly known as blackbird
Y0Gi
User
Beiträge: 1454
Registriert: Freitag 22. September 2006, 23:05
Wohnort: ja

Beitragvon Y0Gi » Freitag 2. Mai 2008, 22:05

IIRC wurde `scoped_session` erst mit Version 0.4 eingeführt.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder