Python 2.1.3 unter linux deinstallieren

Probleme bei der Installation?
iceigel
User
Beiträge: 3
Registriert: Donnerstag 31. Oktober 2002, 18:59

Python 2.1.3 unter linux deinstallieren

Beitragvon iceigel » Donnerstag 31. Oktober 2002, 19:04

hallo,

ich habe python 2.1.3 installiert und will ein programm mit python installieren,
das problem:

Code: Alles auswählen

Traceback (most recent call last):
  File "setup.py", line 22, in ?
    import encode_bitmaps
  File "encode_bitmaps.py", line 5, in ?
    from wxPython.tools import img2py
ImportError: No module named wxPython.tools


ich denke mal, dass das an der version von python liegt (?)
habe in google nach diesem problem gesucht aber nix gefunden.

Wie kann ich die selbskompilierte version von Python 2.1.3 deinstallieren ?

vielen dank schon mal,
iceigel
Benutzeravatar
hans
User
Beiträge: 728
Registriert: Sonntag 22. September 2002, 08:32
Wohnort: Sauerland
Kontaktdaten:

Beitragvon hans » Donnerstag 31. Oktober 2002, 19:22

ich tippe mal, daß das Setup wxPython vorraussetzt und du dieses Paket nicht installiert hast.

Was für ein Linux Distri hast du denn?

Hans
iceigel
User
Beiträge: 3
Registriert: Donnerstag 31. Oktober 2002, 18:59

Beitragvon iceigel » Donnerstag 31. Oktober 2002, 19:53

ok:

Linux SuSE 8.0
Python 2.3.1
wxPythonGTK-py2.1

Also wxPython ist installiert...

ice
Benutzeravatar
hans
User
Beiträge: 728
Registriert: Sonntag 22. September 2002, 08:32
Wohnort: Sauerland
Kontaktdaten:

Beitragvon hans » Donnerstag 31. Oktober 2002, 20:36

Also ich habe mal auf meiner Suse 8.1 CD gestöbert. Da kann ich kein wxPython finden, nur wxGTK-Pakete. Hast due das Paket etwa aus einer anderen Quelle? Dann mußt du dir noch mal die Installationsdateien anschauen.

Ich selbst kenne mich damit nicht aus, weil ich QT bevorzuge.

Hans
iceigel
User
Beiträge: 3
Registriert: Donnerstag 31. Oktober 2002, 18:59

geschafft...

Beitragvon iceigel » Donnerstag 31. Oktober 2002, 20:38

ok finally...

habe die binarys aus /usr/local/bin der alten python-version (2.1) gelöscht,
die binarys der neuen version (2.2) von usr/bin nach usr/local/bin kopiert,
den $PYTHONHOME pfad sicherheitshalber nochma auf /usr/local/bin gesetzt,
wxPython nochma installiert, nachdem gelöscht und dann einfach das programm mit python ./*.py ausgeführt...

Es funktioniert ! :D

danke, thread darf hiermit geschlossen werden,
ice
Benutzeravatar
hans
User
Beiträge: 728
Registriert: Sonntag 22. September 2002, 08:32
Wohnort: Sauerland
Kontaktdaten:

Beitragvon hans » Donnerstag 31. Oktober 2002, 21:27

hehe,

dass sieht mir nicht sauber aus! Bei mir sind die sachen gelinkt

Code: Alles auswählen

/usr/bin/python -> python2.2*

Könnte bei enem Update mal Stress geben.

Hans

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder