Python Launcher/Build Applet und Mac OS X Leopard - nix geht

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
Antworten
ne0h
User
Beiträge: 115
Registriert: Samstag 16. Februar 2008, 11:35

Freitag 21. März 2008, 19:44

Hallo Gemeinde,

nachdem ich mich an meinen Mac gesetzt habe und mein Python aktualisiert habe (zuvor war das vorinstallierte 2.5.1 drauf) auf Version 2.5.2, habe ich in meinem Applications Ordner einen neuen Ordner vorgefunden, namens MacPython 2.5.

Dort finden sich neben IDLE, einem "Extras" Ordner und einem Shell Script zum Updaten auch der "Python Launcher" und das Programm "Build Applet".

Python Launcher soll dafür sorgen, dass Python Skripte direkt durch einen Doppelklick ausgeführt werden. Build Applet soll aus geschriebenen Skripten selbstlaufenden, direkt ausführbare Applikationen erstellen.

Build Applet erstellt zwar eine solche Applikation, aber ausführen lässt sich diese nicht. Nach einem Doppelklick passiert einfach garnichts.

Noch schlimmer ist es mit dem Python Launcher.

Stelle ich über den "Finder" um, dass Dateien mit der Endung .py Standardmäßig mit dem Python Launcher ausgeführt werden sollen, übernimmt er diese Einstellung auch.

Dann starte ich mein Testskript (ein einfaches

Code: Alles auswählen

print "Hallo Welt"
) mit einem Doppelklick. Der Python Launcher startet und gleichzeitig auch die Konsole (auf welcher die Ausgabe stattfinden soll).

Auf der Konsole passiert allerdings nichts, und der Launcher meldet sich nach ca.5 Sekunden mit der Meldung:

"Hello.py could not be launched".

Starte ich den Launcher manuell dann erscheint eine Hinweismeldung, dass der Launcher nicht das Standardprogramm ist für Dateien mit der Endung .py und dass man dies fixen sollte.

Was ja auch passiert mit dem manuellen Zuordnen über den Finder (wie oben beschrieben).

Lasse ich das Skript normal über die Konsole laufen (also mittels: python Hello.py) dann läuft es einwandfrei.

Auch nach über 2 Stunden Suche habe ich nur einen Eintrag in einer Usergroup gefunden in welcher Jemand genau das selbe Problem hat. Siehe hier: http://groups.google.com/group/comp.lan ... 15934ac723


Es besteht zwar auch ein Bugreport, hier: http://bugs.python.org/issue1905

Aber dort ist das Problem etwas anders dargestellt und es existiert auch keine Lösung dafür.

Darum jetzt hier in die Runde: Welcher OS X User hat auch diese Probleme bzw. konnte ähnliches feststellen??


ne0h
ne0h
User
Beiträge: 115
Registriert: Samstag 16. Februar 2008, 11:35

Freitag 21. März 2008, 19:49

P.S.:

Die Python-Icons sind auch verschwunden. Alle .py Dateien werden als Standarddateien angezeigt (also einfach ein weisses Blatt).

Vorher wurden alle Skripte mit Python direkt assoziiert.


ne0h
Antworten