Installation von pypgsql unter OpenSUSE 10.3 [gelöst]

Probleme bei der Installation?
Antworten
ragazzomusic
User
Beiträge: 8
Registriert: Donnerstag 7. September 2006, 12:58

Dienstag 18. März 2008, 13:01

Liebes Forum,

da bin ich mal wieder. :-)

Diesesmal mit Problemen bei der Installation von pypgsql unter OpenSUSE 10.3.

Für 10.3 habe ich leider keine RPM-Pakete mehr unter "Guru" gefunden.
Also muß ich selbst ran :-)

Installiert ist Python 2.5.1 und GCC 4.2.1:
/tmp/pypgsql/pyPgSQL-2.5.1 # python
Python 2.5.1 (r251:54863, Jan 10 2008, 18:01:57)
[GCC 4.2.1 (SUSE Linux)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>
Wenn ich "python setup.py build" ausführe bekomme ich folgende Meldung(en):
/tmp/pypgsql/pyPgSQL-2.5.1 # python setup.py build
sh: pg_config: command not found
sh: pg_config: command not found
running build
running build_py
running build_ext
building 'pyPgSQL.libpq.libpqmodule' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -march=i586 -mtune=i686 -fmessage-length=0 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -g -fPIC -I -I/usr/include/python2.5 -c libpqmodule.c -o build/temp.linux-i686-2.5/libpqmodule.o
libpqmodule.c:78:20: error: Python.h: Datei oder Verzeichnis nicht gefunden
libpqmodule.c:79:26: error: structmember.h: Datei oder Verzeichnis nicht gefunden
libpqmodule.c:80:24: error: fileobject.h: Datei oder Verzeichnis nicht gefunden
In file included from libpqmodule.c:81:
libpqmodule.h:29:22: error: libpq-fe.h: Datei oder Verzeichnis nicht gefunden
libpqmodule.h:30:28: error: libpq/libpq-fs.h: Datei oder Verzeichnis nicht gefunden
In file included from libpqmodule.h:33,
from libpqmodule.c:81:
pgboolean.h:44: error: expected specifier-qualifier-list before ‘PyObject_HEAD’
pgboolean.h:48: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘PgBoolean_Type’
pgboolean.h:52: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
pgboolean.h:53: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
In file included from libpqmodule.h:34,
from libpqmodule.c:81:
pgint2object.h:33: error: expected specifier-qualifier-list before ‘PyObject_HEAD’
pgint2object.h:37: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘PgInt2_Type’
pgint2object.h:41: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
pgint2object.h:42: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
pgint2object.h:43: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
pgint2object.h:44: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
In file included from libpqmodule.h:36,
from libpqmodule.c:81:
pgconnection.h:40: error: expected specifier-qualifier-list before ‘PyObject_HEAD’
pgconnection.h:58: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘PgConnection_Type’
pgconnection.h:60: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
pgconnection.h:62: error: expected ‘)’ before ‘*’ token
In file included from libpqmodule.h:37,
from libpqmodule.c:81:
pgresult.h:48: error: expected specifier-qualifier-list before ‘PyObject_HEAD’
pgresult.h:61: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘PgResult_Type’
pgresult.h:63: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
pgresult.h:65: error: expected ‘)’ before ‘*’ token
In file included from libpqmodule.h:38,
from libpqmodule.c:81:
pglargeobject.h:41: error: expected specifier-qualifier-list before ‘PyObject_HEAD’
pglargeobject.h:62: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘PgLargeObject_Type’
pglargeobject.h:66: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
In file included from libpqmodule.h:39,
from libpqmodule.c:81:
pgnotify.h:36: error: expected specifier-qualifier-list before ‘PyObject_HEAD’
pgnotify.h:45: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘PgNotify_Type’
pgnotify.h:49: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
In file included from libpqmodule.h:40,
from libpqmodule.c:81:
pgversion.h:36: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘PgVersion_Type’
pgversion.h:40: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
In file included from libpqmodule.c:81:
libpqmodule.h:107: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.h:108: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.h:109: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.h:110: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.h:111: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.h:112: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.h:113: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.h:114: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.h:115: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.h:116: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:95: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:96: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:97: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:98: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:99: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:100: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:101: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:102: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:103: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:104: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:162: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:292: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:387: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:441: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:459: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:501: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:622: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:638: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:683: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:809: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:872: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:884: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:896: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:924: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:938: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
libpqmodule.c:952: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘libpqMethods’
libpqmodule.c:1008: warning: return type defaults to ‘int’
libpqmodule.c: In function ‘DL_EXPORT’:
libpqmodule.c:1008: error: expected declaration specifiers before ‘initlibpq’
libpqmodule.c:1208: error: expected ‘{’ at end of input
error: command 'gcc' failed with exit status 1
Wo liegt nun mein Problem (abgesehen davon das ich der absolute Python-Newbie bin)? :roll:

Danke!

Grüsse
Zuletzt geändert von ragazzomusic am Dienstag 25. März 2008, 15:44, insgesamt 1-mal geändert.
Benutzeravatar
Trundle
User
Beiträge: 591
Registriert: Dienstag 3. Juli 2007, 16:45

Dienstag 18. März 2008, 13:11

ragazzomusic hat geschrieben:Wo liegt nun mein Problem?
Du hast die Development-Pakete von Python und PostgreSQL nicht installiert. Dürften bei openSUSE vermutlich `postgresql-devel` und `python-devel` heißen.
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Dienstag 18. März 2008, 17:13

Ist auch die Frage warum du nicht ``psycopg2`` verwendest...
My god, it's full of CARs! | Leonidasvoice vs Modvoice
ragazzomusic
User
Beiträge: 8
Registriert: Donnerstag 7. September 2006, 12:58

Mittwoch 19. März 2008, 22:34

Trundle hat geschrieben: Du hast die Development-Pakete von Python und PostgreSQL nicht installiert. Dürften bei openSUSE vermutlich `postgresql-devel` und `python-devel` heißen.
Hallo Trundle,
hallo Leonidas

Danke für den Tipp. 'python-devel' sollte ich installiert haben, aber ich überprüfe das nochmal. An 'postgresql-devel' habe ich überhaupt nicht gedacht.
Leonidas hat geschrieben: Ist auch die Frage warum du nicht ``psycopg2`` verwendest...
Ich benötige das 'pypgsql'-Paket, da es für den Betrieb einer Kassensoftware notwendig ist. Ist eine Anforderung vom Hersteller...

Grüsse
ragazzomusic
User
Beiträge: 8
Registriert: Donnerstag 7. September 2006, 12:58

Dienstag 25. März 2008, 15:43

Trundle hat geschrieben: Du hast die Development-Pakete von Python und PostgreSQL nicht installiert. Dürften bei openSUSE vermutlich `postgresql-devel` und `python-devel` heißen.
Hallo Trundle,

also "python-devel" hatte ich wie gesagt bereits installiert. Allerdings bin ich nicht auf die Idee gekommen das ich "postgresql-devel" ebenfalls benötigen würde.
Habe ich nachinstalliert und schwupp - lief alles perfekt durch! :-)

Vielen Dank für die schnelle & kompetente Hilfe hier im Forum! Ist immer wieder sehr aufbauend!

Grüsse
Antworten