pySerial seltsames Verhalten...

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
nordish1982
User
Beiträge: 7
Registriert: Sonntag 16. März 2008, 20:46

pySerial seltsames Verhalten...

Beitragvon nordish1982 » Sonntag 16. März 2008, 20:54

Moin Moin aus Zypern,

ich hab ein Problem mit einem pySerial script:

import serial
ser = serial.Serial(0) #open first serial port
print ser.portstr #check which port was realy used
ser.write("hello") #write a string
ser.close() #close port

ist das beispielscript, ich weiss.

das ding is: wenn ich das script zeilenweise in die console hacke funktioniert es bestens, wenn ich jedoch das script als .py datei starte läuft es nich:

Traceback (most recent call last):
File "C:\ROV\serial.py", line 1, in <module>
import serial
File "C:\ROV\serial.py", line 2, in <module>
ser = serial.Serial(0) #open first serial port
AttributeError: 'module' object has no attribute 'Serial'

woran kann das liegen?

pyserial und win32all sind installiert.

für Hilfe wäre ich sehr dankbar, so langsam verzweifel ich daran.
MfG
Nordish
Benutzeravatar
veers
User
Beiträge: 1219
Registriert: Mittwoch 28. Februar 2007, 20:01
Wohnort: Zürich (CH)
Kontaktdaten:

Beitragvon veers » Sonntag 16. März 2008, 21:04

Gib der Datei einen anderen Namen, sie darf nicht gleich heissen wie das Modul und vergiss nicht die pyc Dateien zu entfernen. ;)

Gruss,
Jonas
My Website - 29a.ch
"If privacy is outlawed, only outlaws will have privacy." - Phil Zimmermann
nordish1982
User
Beiträge: 7
Registriert: Sonntag 16. März 2008, 20:46

argh...

Beitragvon nordish1982 » Montag 17. März 2008, 19:09

ok, vielen dank.
jetzt bin ich nich nur ein python-noob, jetzt fühl ich mich auch wie einer :)

cool das hier so schnell eine so hilfreiche antwort kommt
*freu*

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot]