[gelöst]skript nimmt nicht python2.5

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
feldmaus
User
Beiträge: 284
Registriert: Donnerstag 12. Oktober 2006, 16:48

[gelöst]skript nimmt nicht python2.5

Beitragvon feldmaus » Mittwoch 12. März 2008, 02:53

Guten Morgen, :-)

also ich habe das Problem, das meine Python SKripte mein Modul sqlite3 nicht importieren,
da mein Skript immer wieder python2.4, was zur Zeit default ist in Debian Etch, nimmt.
Um das sqlite3 Modul allerdings nutzen zu können muss ich Python2.5 nutzen.
Daher habe ich in meine Skripte folgende erste Zeile,

Code: Alles auswählen

#!/usr/bin/env python2.5

Leider funktioniert das aber nicht.
Hat Jemand eine Idee?

Grüße Markus
Zuletzt geändert von feldmaus am Donnerstag 13. März 2008, 23:18, insgesamt 1-mal geändert.
BlackJack

Beitragvon BlackJack » Mittwoch 12. März 2008, 06:58

Wie rufst Du das Skript denn auf?
querdenker
User
Beiträge: 424
Registriert: Montag 28. Juli 2003, 16:19
Wohnort: /dev/reality

Beitragvon querdenker » Mittwoch 12. März 2008, 07:46

Schau dir mal deine Umgebungsvariablen an.
Ich kenne mich nicht mit Debian aus, aber ich schätze mal das die ganzen Vars noch auf die python2.4-Installation zeigen.

Du könntest den Shebang so umschreiben, das er auf die 2.5er Installation zeigt.
Nicht getestet, da kein Debian zur Hand:
[code=]#!/pfad/zu/python2.5/python[/code]

Funktioniert natürlich nur, wenn das Script ausführbar ist und du es nicht mit
[code=]python script.py[/code]
aufrufst.
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Mittwoch 12. März 2008, 09:55

querdenker hat geschrieben:Schau dir mal deine Umgebungsvariablen an.
Ich kenne mich nicht mit Debian aus, aber ich schätze mal das die ganzen Vars noch auf die python2.4-Installation zeigen.

Naja, Debians python2.5-Paket installiert sich als python2.5 im Pfad, also sollte ``env`` durchaus funktionieren.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
feldmaus
User
Beiträge: 284
Registriert: Donnerstag 12. Oktober 2006, 16:48

Beitragvon feldmaus » Mittwoch 12. März 2008, 11:18

Es war gestern schon ein bischen spät, sonst hätte ich noch ergänzt, dass ich
mein Start Skript startGUI.pyw lautet, d.h. mein Skript wird entweder durch
Doppelklick auf die Datei gestartet oder über meinen Debugger in Emacs
pdb startGUI.pyw.
Ich habe mir meine Umgebungsvariablen schon angeschaut mit print sys.path
bzw. print sys.path(), Dabei ist raußgekommen, dass er im Debugger Python2.4 nimmt. Den Shebang habe ich über all umgeschrieben in,

Code: Alles auswählen

#!/usr/bin/env python2.5

Oder liegt das an meinem Debugger in Emacs, dass er immer Python 2.4 nimmt?
Ich habe einen selbstkompilierten Emacs 22.1.1. Wie kann ich den Emacs so kompilieren auf meinem Debian System, dass er auf Python2.5 ausgerichtet ist?
Das heißt beim Doppelklick auf meine startGUI.pyw müsste er Python2.5 nehmen?
feldmaus
User
Beiträge: 284
Registriert: Donnerstag 12. Oktober 2006, 16:48

Beitragvon feldmaus » Mittwoch 12. März 2008, 11:44

feldmann_markus hat geschrieben:Oder liegt das an meinem Debugger in Emacs, dass er immer Python 2.4 nimmt?
Ja
feldmann_markus hat geschrieben:Ich habe einen selbstkompilierten Emacs 22.1.1. Wie kann ich den Emacs so kompilieren auf meinem Debian System, dass er auf Python2.5 ausgerichtet ist?
In Emacs unter Settings nach pdb suchen und pdb2.5 einstellen.

In meinem Debugger läuft zwar jetzt python2.5, dafür findet er PyQt4 allerdings nicht. :cry: Das Packet python-qt4 ist allerdings nicht für python2.5 ausgelegt. :cry:
feldmaus
User
Beiträge: 284
Registriert: Donnerstag 12. Oktober 2006, 16:48

Beitragvon feldmaus » Donnerstag 13. März 2008, 23:18

Es lag an meinem Debugger. Also einfach in Emacs den pdb2.5 einstellen.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder