Stani's Python Editor in Ubuntu 7.10

Probleme bei der Installation?
rednose
User
Beiträge: 8
Registriert: Montag 20. November 2006, 20:52

Stani's Python Editor in Ubuntu 7.10

Beitragvon rednose » Donnerstag 24. Januar 2008, 18:16

Ich hatte mit sudo alien -i /home/michael/Dokumente/spe-0.8.3c-wx2.6.10-py2.4.rpm
Stani's Python Editor als deb-Paket installiert.
Beim Start von spe bekam ich folgende Meldung:

Traceback (most recent call last):
File "/usr/bin/spe", line 3, in <module>
import _spe.SPE
ImportError: No module named _spe.SPE

Per googeln habe ich ein paar Beiträge quer im Netz verteilt gefunden, wo dieser Fehler auch gemeldet wurde.
(Von Ubuntu-Usern). Leider ohne Lösung.

Bisher habe ich den SPE unter Windows benutzt (ohne Probleme)
In Ubuntu habe ich auch schon mit dem Synaptic-Paket keinen Erfolg gehabt
und mir daher die neueste Version als rpm gezogen.

Hat jemand eine Idee?

Gruß

Micha
rayo
User
Beiträge: 773
Registriert: Mittwoch 5. November 2003, 18:06
Wohnort: Schweiz
Kontaktdaten:

Beitragvon rayo » Donnerstag 24. Januar 2008, 18:40

Hi

Ubuntu hat doch SPE im normale Packetmanager oder?
Warum haste nicht das genommen?

Gruss
rednose
User
Beiträge: 8
Registriert: Montag 20. November 2006, 20:52

Beitragvon rednose » Donnerstag 24. Januar 2008, 19:12

Das ist nicht die aktuellste Version. Mit dem Paket bekam ich einen Fehler,
den ich noch öfter in vielen threads gefunden hatte:
AttributeError: 'Throbber' object has no attribute '_fileName'
Nach Durchwühlen unzähliger posts und replies bin ich dann dem Rat gefolgt,
die rpm-Version zu nehmen.


Gruß

Micha
rednose
User
Beiträge: 8
Registriert: Montag 20. November 2006, 20:52

Beitragvon rednose » Donnerstag 24. Januar 2008, 20:56

So....mir nicht verständlich, aber die Installation des o.g. Paketes wurde in
/usr/lib/python2.4/_spe vorgenommen...
python -V ergibt bei mir aber 2.5.1
Okay....nach dem Start aus /usr/lib/python2.4/_spe habe ich dann noch die Fehlermeldung bekommen: "/usr/lib/python2.4/site-packages/_spe/sm/wxp/smdi.py",
line 991, in setTitle
self.SetTitle(self.pageTitle)
AttributeError: 'MdiSplitChildFrame' object has no attribute 'SetTitle'

Wieder 'nen Wolf gegoogelt und hier http://osdir.com/ml/python.spe.user/200 ... 00028.html (vom 22.11.2006!) das Folgende gelesen und befolgt:
You'll need to replace _spe/sm/wxp/smdi.py with the attached file. I
am working on a new version.

Stani

Jetzt läuft SPE 0.8.3c ! (Bis jetzt ohne Fehler)

Gruß

Micha
DocFisher
User
Beiträge: 50
Registriert: Donnerstag 29. November 2007, 21:04
Wohnort: Berlin
Kontaktdaten:

noch aktuell?

Beitragvon DocFisher » Montag 4. Februar 2008, 13:58

Hallo,

ich nutze SPE auch unter Gutsy. In den Paketquellen sind nur ältere Versionen.
Aber mittels svn kannst Du sehr einfach die aktuellste Version nutzen. Schau doch mal hier:http://pythonide.blogspot.com/2007/02/how-to-download-latest-spe-from_26.html

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder