ActivePython 2.5.1 mit Tcl/TK 8.5?

Fragen zu Tkinter.
Antworten
Benutzeravatar
numerix
User
Beiträge: 2696
Registriert: Montag 11. Juni 2007, 15:09

Freitag 18. Januar 2008, 19:15

Hallo,

ich benutze die aktuelle ActivePython-Version unter Linux und möchte eine TK(inter) Anwendung entwickeln. Da die allerneueste Version 8.5 von Tcl/Tk erheblich schönere Widgets mitbringt, würde ich diese natürlich auch gerne verwenden. ActivePython mit Python 2.5.1 bringt Tcl/Tk 8.4 mit.

Gibt es eine (nicht zu aufwendige) Möglichkeit, die Version 8.5 hier einzubinden?
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Freitag 18. Januar 2008, 19:23

Ich vermute Tkinter muss gegen Tk 8.5 neu kompiliert werden. Findest du das aufwändig?
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Benutzeravatar
numerix
User
Beiträge: 2696
Registriert: Montag 11. Juni 2007, 15:09

Samstag 19. Januar 2008, 11:01

Ich vermute Tkinter muss gegen Tk 8.5 neu kompiliert werden. Findest du das aufwändig?
Das weiß ich nicht, weil das meinen momentanen Kenntnis-/Erfahrungsstand übersteigt. Ich hatte gehofft, dass es mit ein paar Verlinkungen oder Einträgen in irgendwelchen config-Dateien getan wäre.

Ansonsten: Da beide Produkte von ActiveState kommen, bin ich guter Hoffnung, dass im Laufe einiger Monate - vielleicht mit Python 2.6 - auch die Tk-Einbindung aktualisiert wird. Dann wird meine Anwendung eben vorläufig noch nicht ganz so schick aussehen wie irgendwann später.

Danke trotzdem!
Antworten