open Befehl-Frage

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
JackJohnson
User
Beiträge: 8
Registriert: Donnerstag 6. Dezember 2007, 23:50

open Befehl-Frage

Beitragvon JackJohnson » Donnerstag 6. Dezember 2007, 23:59

Hallo,

ich habe zwei Programme eins das wunderbar geht und das andere basiert darauf ist aber etwas umfangreicher...

Bei Nr 1. öffne ich eine Datei mit

def oeffnen(name):
file=open(name,r)
lines=file.readlines()
.
.
.
return x,y,z(array)

name=(test.txt)
x,y,z=oeffnen(name

Alles ist toll und funktioniert, bei Nr. 2 ist alles gleich nur und da kommt dann einfach :

Traceback (most recent call last):
File "*****", line 102, in ?
x,y,z=oeffnen(name)
File "*****", line 4, in oeffnen
file=open(name,'r')
TypeError: an integer is required

Mache ich statt den r eine Zah, dann macht er weiter und nöllt später, dass
lines=file.readlines()
AttributeError: 'int' object has no attribute 'readlines'

Ich hoffe, dass jmd damit was anfangen kann ! Danke im voraus

JJ
BlackJack

Beitragvon BlackJack » Freitag 7. Dezember 2007, 00:19

Gewöhn Dir Sternchen-Imports ab.
Y0Gi
User
Beiträge: 1454
Registriert: Freitag 22. September 2006, 23:05
Wohnort: ja

Beitragvon Y0Gi » Freitag 7. Dezember 2007, 00:30

Der Code ist unvollständig (sogar einzelne Zeilen) und auf den ersten Blick an mehreren Stellen falsch. Poste doch bitte die entsprechenden Stellen komplett und dann bitte in Code-Tags mit Python-Syntaxhervorhebung.
sma
User
Beiträge: 3018
Registriert: Montag 19. November 2007, 19:57
Wohnort: Kiel

Beitragvon sma » Sonntag 9. Dezember 2007, 18:17

Um BlackJacks kryptischen Kommentar zu erläutern: Du glaubst, die Funktion `__builtin__.open` zu benutzen, benutzt aber aller Wahrscheinlichkeit nach `os.open`, da du ein `from os import *` oder so ähnlich im Code stehen hast.

Stefan
JackJohnson
User
Beiträge: 8
Registriert: Donnerstag 6. Dezember 2007, 23:50

Beitragvon JackJohnson » Montag 10. Dezember 2007, 11:44

Hat sich schon nach einem Neustart wieder funtktioniert....

Trotzdem Danke !
Zap
User
Beiträge: 533
Registriert: Freitag 13. Oktober 2006, 10:56

Beitragvon Zap » Montag 10. Dezember 2007, 11:47

Hoffe innerlich das der op die gegebenen Ratschläge trotzdem gelesen hat... :?
Weil ein Neustart hilft höchstens in der Interactive Shell.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder