py2exe dos-shell verstecken

Hier werden alle anderen GUI-Toolkits sowie Spezial-Toolkits wie Spiele-Engines behandelt.
Antworten
AllesMeins
User
Beiträge: 63
Registriert: Donnerstag 20. November 2003, 13:45
Wohnort: Frankfurt/M.

Mittwoch 18. Februar 2004, 15:13

Hiho,

ich hab ja eigentlich vermeiden wollen nach diesem leidigen thema hier zu fragen, aber mir bleibt wohl keine andere Möglichkeit.
Wie kann ich verhindern, das bei einem mit py2exe compilierten Programm die dos-shell mit aufploppt?

Ich habe dazu schon gesucht und bin in den meisten Fällen auf folgende antworten gestossen:

Script umbenennen in .pyw:

Geht nicht. wenn ich das mache und dann versuche py2exe auszuführen legt er einfach keine Dateien an. eine Fehlermeldung gibt es auch nicht

py2exe mit Flag -w starten:
Geht nicht. Diese Option gibt es bei mir gar nicht:

D:\Python23>python setup.py py2exe -w
usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
[...]
error: option -w not recognized

Andere Antworten habe ich weder hie rnoch bei googel finden können...

Irgendwelche Ideen, die funktionieren?

Grüsse

Marc
Gast

Mittwoch 18. Februar 2004, 21:24

doch das geht!
bei mir jedenfalls.
steht auch im setup script

Code: Alles auswählen

scripts("datei.pyw")
das sollte rein.
und du hsat recht: die -w option gibt es bei mir auch nciht... :?
DER Olf
User
Beiträge: 283
Registriert: Mittwoch 24. Dezember 2003, 19:32

Mittwoch 18. Februar 2004, 21:28

sry, wieder vergessen einzuloggen^^.

was hast du denn schon alles mit py2exe gemacht?
AllesMeins
User
Beiträge: 63
Registriert: Donnerstag 20. November 2003, 13:45
Wohnort: Frankfurt/M.

Mittwoch 18. Februar 2004, 23:34

Argh... wie war das mit dem wald vor lauter Bäumen...?
Ich bin darauf reingefallen das in der Beispiel setup.py von py2exe setup(console=["script.py"]) steht. Das durch 'windows' ersetzt und schon klappt es...

*wo ist der Kopf auf Tastatur hämmer smilie*
Antworten