[gelöst] Vim und Kommentarzeilen

Alles, was nicht direkt mit Python-Problemen zu tun hat. Dies ist auch der perfekte Platz für Jobangebote.
Antworten
Jan-Peer
User
Beiträge: 166
Registriert: Dienstag 2. Oktober 2007, 10:55

Montag 19. November 2007, 09:37

Hallo zusammen,

mein vim ist leider der festen Ansicht, daß mit # beginnende Zeilen in Spalte 0 zu beginnen haben. Nachdem Meister Google mir in vertretbarer Zeit leider auch keine Lösung anbieten konnte, möchte ich die Frage mal an Euch stellen: Weiß jemand hier zufällig, wie ich dem Editor dieses Verhalten austreiben kann?

Schönen Gruß

Jan-Peer
Zuletzt geändert von Jan-Peer am Montag 19. November 2007, 13:59, insgesamt 1-mal geändert.
Jan-Peer
User
Beiträge: 166
Registriert: Dienstag 2. Oktober 2007, 10:55

Montag 19. November 2007, 13:59

Ok, offensichtlich war smartindent schuld. Seit ich es deaktiviert habe, tritt das Problem nicht mehr auf.
Leonidas
Administrator
Beiträge: 16024
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Montag 19. November 2007, 14:47

Ich denke dass kannst du mit der Option `fo` beeinflussen. Das hatte ich letztens, denn wenn `fo` kein `t` enthält, dann ignoriert vim `textwidth`.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Antworten