Python2.3 und Fedora Core 1 nicht möglich?

Probleme bei der Installation?
Benutzeravatar
hans
User
Beiträge: 728
Registriert: Sonntag 22. September 2002, 08:32
Wohnort: Sauerland
Kontaktdaten:

Python2.3 und Fedora Core 1 nicht möglich?

Beitragvon hans » Samstag 7. Februar 2004, 00:09

Habe gerade mal in einem Wahnsinnsanfall Python2.3 installiert. Sieht miomentan nicht so aus, als wenn ich damit glücklich werde. Dabei habe ich die RPM's für Fedora von www.python.org genommen. Ich Denke einmal, mit Redhat würde es ähnliche Probleme geben. Hier einmal eine Kostprobe der Fehlermeldungen

Code: Alles auswählen

[root@rosi bin]# ln -s /usr/bin/python2.3 ./python
[root@rosi bin]# python
Python 2.3.3 (#1, Feb  3 2004, 17:03:41)
[GCC 3.3.2 20031022 (Red Hat Linux 3.3.2-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>
[root@rosi bin]# redhat-config-printer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 30, in ?
    from rhpl.translate import _, N_
ImportError: No module named rhpl.translate
[root@rosi bin]# yum search python
Traceback (most recent call last):
  File "/usr/bin/yum", line 22, in ?
    import yummain
ImportError: Bad magic number in /usr/share/yum/yummain.pyc
[root@rosi bin]#
Hat jemand ne Lösung oder soll ich den alten Zustand wieder herstellen?

Hans
Benutzeravatar
Dookie
Python-Forum Veteran
Beiträge: 2010
Registriert: Freitag 11. Oktober 2002, 18:00
Wohnort: Salzburg
Kontaktdaten:

Beitragvon Dookie » Samstag 7. Februar 2004, 01:16

Hi Hans,

yum, was immer das ist, scheint da das Problem zu sein. Laut Fehlermeldung ist die "usr/share/yum/yummain.pyc" nicht aktuell, eventuell erstmal yum aktualisieren.

Ich hab Python2.3 unter Debian-SID und es läuft alles prächtig.

btw. es ist nicht nötig python als Root zu starten.


Gruß

Dookie
Benutzeravatar
hans
User
Beiträge: 728
Registriert: Sonntag 22. September 2002, 08:32
Wohnort: Sauerland
Kontaktdaten:

Beitragvon hans » Samstag 7. Februar 2004, 13:34

Fedora / RedHat ohne YUM ist wie Wndows XP ohne MSI :D

OK, könnte nochmals apt-get probieren. Aber redhat-config-.... geht auch nicht, und das ist schon dramatischer wenn die standardmässigen Konfigurationstools nicht gehen.

Ich hatte blind drauf gehofft, dass es da keine Probs gibt, weil die Packages für Fedora ausgewiesen waren.

Ich wandele übrigens nur zu Administrationszwecken und Installationsarien unter den Fittichen von root. Für YUM und redhat-config.... benötigt man root - Rechte


Hans
Benutzeravatar
Dookie
Python-Forum Veteran
Beiträge: 2010
Registriert: Freitag 11. Oktober 2002, 18:00
Wohnort: Salzburg
Kontaktdaten:

Beitragvon Dookie » Samstag 7. Februar 2004, 13:50

du kannst aber auch verschiedene Versionen von Python installiert haben, dann lass halt für die veralteten yum und config-sachen den link /usr/bin/python auf python2.1 stehen und mach einen /usr/bin/python2.3 zum 2.3-Interpreter, falls nicht schon vorhanden.


Gruß

Dookie
Benutzeravatar
hans
User
Beiträge: 728
Registriert: Sonntag 22. September 2002, 08:32
Wohnort: Sauerland
Kontaktdaten:

Beitragvon hans » Samstag 7. Februar 2004, 14:18

Also ich habe das mal mit der zusätzlichen Version probiert scheint zu laufen. Falls jemand in den genuß kommt, dass er dieses auch machen mus: Ich mußte vorher den symbolischen Link /usr/bin/python löschen, sonst wäre nur ein Update möglich gewesen.

So sieht dann ein funktionierendes yum aus

Code: Alles auswählen

[root@rosi Fedora]# yum search python
Gathering header information file(s) from server(s)
Server: Test Linux 2.6-Test prerelease kernels for RHL9 / rawhide
Server: Fedora Core 1 - i386 - Base
Server: Livna.org Fedora Compatible Packages (stable)
Server: Livna.org Fedora Compatible Packages (unstable)
Server: Fedora Core 1 - i386 - Released Updates
Server: Fedora Core 1 - i386 - Testing Updates
Server: Fedora Core 1 ( xcyborg / bleeding )
Server: Fedora Core 1 ( xcyborg / stable )
Finding updated packages
Downloading needed headers
Looking in available packages for a providing package
Available package: mod_python.i386 0:3.0.4-0.1 from updates-released matches with
 mod_python
Available package: gnome-python2-applet.i386 0:2.0.0-2 from base matches with
 gnome-python2-applet
Available package: beecrypt-python.i386 0:3.0.1-0.20030630.1 from base matches with
 Files needed for python applications using beecrypt.
Available package: beecrypt-python.i386 0:3.0.1-0.20030630.1 from base matches with
 beecrypt-python
Available package: boost-python.i386 0:1.30.2-2 from base matches with
 boost-python
Available package: boost-python-devel.i386 0:1.30.2-2 from base matches with
 boost-python-devel
Available package: libxslt-python.i386 0:1.0.33-2 from base matches with
 libxslt-python
Available package: gnome-python2-gnomevfs.i386 0:2.0.0-2 from base matches with
 gnome-python2-gnomevfs
Available package: gnome-python2-nautilus.i386 0:2.0.0-2 from base matches with
 gnome-python2-nautilus
Available package: gnome-python2-gnomeprint.i386 0:2.0.0-2 from base matches with
 gnome-python2-gnomeprint
Available package: gnome-python2-gconf.i386 0:2.0.0-2 from base matches with
 gnome-python2-gconf
Available package: pydict.noarch 0:0.3.0-5 from base matches with
 Wörterbuch Englisch/Chinesisch, mit python/gtk geschrieben
12 results returned
Looking in installed packages for a providing package
Installed package: python-devel.i386 0:2.2.3-7 matches with
 python-devel
Installed package: python-docs.i386 0:2.2.3-7 matches with
 python-docs
Installed package: python2.3-tools.i386 0:2.3.3-1pydotorg matches with
 python2.3-tools
Installed package: gnome-python2-bonobo.i386 0:2.0.0-2 matches with
 gnome-python2-bonobo
Installed package: python2.3-docs.i386 0:2.3.3-1pydotorg matches with
 python2.3-docs
Installed package: MySQL-python.i386 0:0.9.1-9 matches with
 MySQL-python
Installed package: python2.3-devel.i386 0:2.3.3-1pydotorg matches with
 python2.3-devel
Installed package: libxml2-python.i386 0:2.5.11-1 matches with
 libxml2-python
Installed package: rpm-python.i386 0:4.2.1-0.30 matches with
 rpm-python
Installed package: gnome-python2-canvas.i386 0:2.0.0-2 matches with
 gnome-python2-canvas
Installed package: gnome-python2.i386 0:2.0.0-2 matches with
 gnome-python2
Installed package: python2.3.i386 0:2.3.3-1pydotorg matches with
 python2.3
Installed package: python.i386 0:2.2.3-7 matches with
 python
Installed package: gnome-python2-gtkhtml2.i386 0:2.0.0-2 matches with
 gnome-python2-gtkhtml2
Installed package: python-tools.i386 0:2.2.3-7 matches with
 python-tools
Installed package: rpm404-python.i386 0:4.0.4-8x.27 matches with
 rpm404-python
Installed package: postgresql-python.i386 0:7.3.4-11 matches with
 postgresql-python
Installed package: python2.3-tkinter.i386 0:2.3.3-1pydotorg matches with
 python2.3-tkinter
Installed package: python-optik.noarch 0:1.4.1-1 matches with
 python-optik
Installed package: mod_python.i386 0:3.0.3-3 matches with
 mod_python
20 results returned
[root@rosi Fedora]#
Nicht schön, aber aussagekräftig!

Warten wir es mal ab, ob es sich bewährt.

Hans

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder