Problem bei python!!!

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
Antworten
khalil123
User
Beiträge: 2
Registriert: Sonntag 23. September 2007, 12:48

Sonntag 23. September 2007, 12:55

hi
also ich bin ein totaler anfänger was sich mit python betrifft und hab schon mal ein problem
1. problem:::ich öffne python shell (IDLE) und schreibe
from turtle import*
danach schreib ich forward (z.b50) und da kommt schon die erste fehlangabe


"Traceback (most recent call last):
File "<pyshell#1>", line 1, in <module>
forward(100)
File "C:\Python30\lib\lib-tk\turtle.py", line 681, in forward
def forward(distance): _getpen().forward(distance)
File "C:\Python30\lib\lib-tk\turtle.py", line 666, in _getpen
_pen = Pen()
File "C:\Python30\lib\lib-tk\turtle.py", line 650, in __init__
setup(width=_width, height= _height, startx=_startx, starty=_starty)
File "C:\Python30\lib\lib-tk\turtle.py", line 764, in setup
if startx >= 0 or startx == None:
TypeError: unorderable types: NoneType() >= int()


was ist das problem hier


2. problem
immer wenn sich turtle graphics offnet zeigt es die zeichnung nicht sondern eine weisse fläche danach muss ich das vom taskmanager beenden
benötige ich vlt ein programm um turtle graphics angezeigt zu bekommen
wenn ja welches


ich wäre dankbar für jede hilfe
mfg khalil
BlackJack

Sonntag 23. September 2007, 13:38

Wenn ich die Pfadangaben im Traceback richtig interpretiere könntest Du erst einmal eine stabile Python-Version installieren und nicht die erste Alpha von Python 3.0. Aktuell müsste 2.5.1 sein.
khalil123
User
Beiträge: 2
Registriert: Sonntag 23. September 2007, 12:48

Sonntag 23. September 2007, 14:19

leider ist es bei 2.5.1 genau so
Benutzeravatar
birkenfeld
Python-Forum Veteran
Beiträge: 1603
Registriert: Montag 20. März 2006, 15:29
Wohnort: Die aufstrebende Universitätsstadt bei München

Sonntag 23. September 2007, 14:20

Das kann ich mir nicht vorstellen.

EDIT: so, jetzt gibts auch im 3k SVN keine Probleme mehr.
Dann lieber noch Vim 7 als Windows 7.

http://pythonic.pocoo.org/
Antworten