PostgreSQL + Django = Ident-Auth. fehlgeschlagen

Sockets, TCP/IP, (XML-)RPC und ähnliche Themen gehören in dieses Forum
Antworten
Panke
User
Beiträge: 185
Registriert: Sonntag 18. März 2007, 19:26

Samstag 7. Juli 2007, 14:01

Guten Tag,

ich wollte das Django Tutorial durcharbeiten und bin dabei auf ein Problem gestoßen: Ich habe keine Ahnung von Datenbanken. Naja, was soll's.
Da ich hier unter Ubuntu bin, hab ich mir postgreSQL 8.2 nach dieser
installiert und auch den Schritt unter "Einrichtung" befolgt. Danach in pgAdmin III eine Datenbank angelegt (Name: testdb, Codierung: UTF8, Eigentümer: postgres).

in der settings.py steht:
DATABASE_ENGINE = 'postgresql_psycopg2'
DATABASE_NAME = 'testdb'
DATABASE_USER = 'postgres'
DATABASE_PASSWORD = 'geheim' #Das Passwort, dass ich unter Einrichtung mit ALTER USER postgres WITH PASSWORD 'geheim'; angelegt habe
DATABASE_HOST = ''
DATABASE_PORT = ''

Leider gibt mir:

Code: Alles auswählen

python manage.py syncdb

Code: Alles auswählen

self.connection = Database.connect(conn_string, **self.options)
psycopg2.OperationalError: FATAL:  Ident-Authentifizierung für Benutzer »postgres« fehlgeschlagen
aus.

Leider, weiß ich nicht, was ich falsch gemacht habe und wie ich das richtig einrichte. Muss ja irgendwas mit den Zugriffsrechten zu tun haben. Hab in der Django-Doku und hier im Forum leider nüx gefunden.

Hoffe ihr könnt helfen.

Panke

Edit: Na, super. Wo ich die config hier im Forun lese gedacht: Obwohl da zwar eigentlich "set empty string for localhost" bei DATABASE_HOST steht, probier mal 127.0.0.1 und es hat geklappt ..

Ich lass das mal für andere Schnarchnasen hier so stehen.
apollo13
User
Beiträge: 827
Registriert: Samstag 5. Februar 2005, 17:53

Samstag 7. Juli 2007, 23:42

Dazu passt etwas ähnliches bei Mysql super:
Sollte man wie ich den Mysql-Server (irgendwo im Net) lokal auf den Rechner Tunneln (ssh-tunneling) muss man als Host 127.0.0.1 angeben und nicht localhost!
Warum?
Weil Mysql bei localhost eine Verbindung über sockets aufbauen will und nicht über TCP, das ist dann natürlich nen Problem.
Antworten