OpenOffice 2.2. mit Python und SPYCE

Probleme bei der Installation?
Christof
User
Beiträge: 4
Registriert: Mittwoch 25. April 2007, 15:40

OpenOffice 2.2. mit Python und SPYCE

Beitragvon Christof » Mittwoch 25. April 2007, 16:41

Hallo zusammen,
Ich versuche einen ServerPDF-OO auf einem Windows XP Pro mit OO-2.2 (deutsch) zu installieren. Damit hat wahrscheinlich kaum jemand zu tun gehabt.

Mein Frage ist:
wie funktioniert SPYCE mit Python vom OpfenOffice?
Es ist ein PyUNO notwendig was allerdings immer beim OpfenOffice mitgeliefert wird.
Kann ich es irgendwie testen?
Spyce server wird in dieser Lösung mit folgender Batch aus dem Verzeichnis
C:\Programme\OpenOffice.org 2.2\program\ServPDF-OO\Spyce_Webserver.bat

Inhalt ------------------
cd spyce
python.bat 'C:\Programme\OpenOffice.org 2.2\program\ServPDF-OO\spyce\spyce.py -l'
Ende-Inhalt -------------------

gestartet.
Hier bekomme ich eine Fehlermeldung:
„Das System kann den angegebenen Pfad nicht finden.“

Die python.bat kann ich ohne Fehler starten aber sind "set" Einstellungen für Windows notwendig?
Für jeden Tipp, wie richtig sein soll, wäre ich sehr dankbar.
Danke
Christof
Christof
User
Beiträge: 4
Registriert: Mittwoch 25. April 2007, 15:40

Beitragvon Christof » Mittwoch 25. April 2007, 16:50

Ups,
hier der korrekte Inhalt der Datei
C:\Programme\OpenOffice.org 2.2\program\ServPDF-OO\Spyce_Webserver.bat

Inhalt ------------------
cd spyce
..\..\Program\python.bat spyce.py -l
Ende-Inhalt -------------------

Sorry.
Christof
BlackJack

Beitragvon BlackJack » Mittwoch 25. April 2007, 17:27

Schau mal auf die Pfadnamen. Im Pfad den Du angegeben hast ist 'program' klein geschrieben und im Batch-Skript steht 'Program'.
Christof
User
Beiträge: 4
Registriert: Mittwoch 25. April 2007, 15:40

Beitragvon Christof » Mittwoch 25. April 2007, 17:49

Danke für Deine Mühe
aber Windows Verzeichnisnamen sind nicht case-sensitive.
Gruß
Christof
BlackJack

Beitragvon BlackJack » Mittwoch 25. April 2007, 21:27

Von wo rufst Du die Datei auf? Ist in dem Verzeichnis ein Unterverzeichnis mit dem Namen `spyce`? Füg mal ``echo irgendwas``-Zeilen ein, um zu sehen bis wohin das Batch-Skript mit der Ausführung kommt.
Christof
User
Beiträge: 4
Registriert: Mittwoch 25. April 2007, 15:40

Beitragvon Christof » Donnerstag 26. April 2007, 11:38

Hallo,
das ist wahrscheinlich eine Kleinigkeit bei dem python Aufruf.
Mit dem Spring in „spyce“ Verzeichnis funktioniert es aber wie wird spyce richtig aufgerufen?
Hier die Ausgabe aus der DOS-Box:
----
C:\Programme\OpenOffice.org 2.2\program\ServPDF-OO\spyce>Spyce_Webserver.bat

C:\Programme\OpenOffice.org 2.2\program\ServPDF-OO\spyce>'C:\Programme\OpenOffic
e.org 2.2\program\python.bat'
Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung
ist falsch.

C:\Programme\OpenOffice.org 2.2\program\ServPDF-OO\spyce>
----

Wie man in der letzten Zeile sieht, bleibt es im spyce hängen. Hier noch einmal der Inhalt von Spyce_Webserver.bat:
----
cd spyce
..\..\Program\python.bat spyce.py -l
----

Natürlich in "spyce" Verzeichnis liegt auch die Datei spyce.py.

Danke und Grüße
Christof

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder