Problem "Flow in Games" Umsetzung mit Tkinter

Fragen zu Tkinter.
apollo13
User
Beiträge: 827
Registriert: Samstag 5. Februar 2005, 17:53

Beitragvon apollo13 » Sonntag 18. März 2007, 12:49

Die Auslastung liegt bei mir konstant bei 0%.

Aber in 2 Sekunden habe ich das Spiel nun wirklich nicht geschafft:
Alles Plankton gefressen!
Bravo! Nur 2.170 Sekunden!
Benutzeravatar
Michael Schneider
User
Beiträge: 567
Registriert: Samstag 8. April 2006, 12:31
Wohnort: Bremen
Kontaktdaten:

Beitragvon Michael Schneider » Montag 19. März 2007, 07:23

apollo13 hat geschrieben:Die Auslastung liegt bei mir konstant bei 0%.

Aber in 2 Sekunden habe ich das Spiel nun wirklich nicht geschafft:
Alles Plankton gefressen!
Bravo! Nur 2.170 Sekunden!


Uuups... sieht nach einem (oder mehreren) Bugs aus. Wie wäre es mit einem ausführlichen Bugreport a la Microsoft (Rechnername, -hardware, -software, Lizenzen, Peripherie, Vertragspartner...) ;-)

Aber im Ernst, passiert das jedes mal? Was sagt die Stopuhr unten im "Spielfenster"?

Grüße,
Michel
Diese Nachricht zersört sich in 5 Sekunden selbst ...
apollo13
User
Beiträge: 827
Registriert: Samstag 5. Februar 2005, 17:53

Beitragvon apollo13 » Montag 19. März 2007, 11:23

Okay kannst du haben^^
Also neuer Versuch:
Alles Plankton gefressen!
Bravo! Nur 0.960 Sekunden!

Systemmonitor (gnome) zeigt mir 2% Auslastung auf beiden Prozessoren an, die 0% von follow.py dürften stimmen. Die Zeit verstreicht total langsam, kA warum^^

Mein Sys:
- Intel Core 2 Duo Prozessor T7200 (2.0GHz/4MB/667FSB)
- 2048 MB DDR2-RAM 667FSB
- 512 MB Geforce Go 7700
- Ubuntu 6.10
Python:
Python 2.4.4c1 (#2, Oct 11 2006, 21:51:02)
[GCC 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)] on linux2


Wenn du noch etwas brauchst nur sagen :)

EDIT: Außer Lizenzen etc. versteht sich ;)
Benutzeravatar
Michael Schneider
User
Beiträge: 567
Registriert: Samstag 8. April 2006, 12:31
Wohnort: Bremen
Kontaktdaten:

Beitragvon Michael Schneider » Mittwoch 21. März 2007, 17:57

Hi Apollo,

wie hier im parallelen Thread beschrieben liegt das Problem an time.clock.
http://www.python-forum.de/viewtopic.php?p=62434#62434
Bitte ersetzen durch time.time und dann funzt es. :-)

Grüße,
Michel
Diese Nachricht zersört sich in 5 Sekunden selbst ...
apollo13
User
Beiträge: 827
Registriert: Samstag 5. Februar 2005, 17:53

Beitragvon apollo13 » Mittwoch 21. März 2007, 20:09

Ja, geht eindeutig besser :)

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder