Installationsproblem mit pyPgSQL

Probleme bei der Installation?
Antworten
philippjosefrichard
User
Beiträge: 8
Registriert: Freitag 3. Februar 2006, 06:28

Sonntag 30. Juli 2006, 10:56

Hallo Python-Forum

Betriebssystem FC3, python-2.3.4-13.1
Habe Probleme beim Installieren eines python-Modules:
sh: pg_config: command not found
Ist das der Grund f}r die unz{hligen Fehlermeldungen (siehe unten)

Passen etwa python-2.3.4-13.1 und pyPgSQL-2.5.1 nicht zusammen?
Es gibt aber kein {lteres pyPgSQL zum download

Vielen Dank f}r Tips
Philipp

gunzip pyPgSQL-2.5.1.tar.gz
tar xvf pyPgSQL-2.5.1.tar
cd pyPgSQL-2.5.1
python setup.py build


[root@philipp pyPgSQL-2.5.1]# python setup.py build
macht eine lange Fehlerliste:

sh: pg_config: command not found
sh: pg_config: command not found
running build
running build_py
running build_ext
building 'pyPgSQL.libpq.libpqmodule' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict-prototypes
-fPIC -I -I/usr/local/include/python2.4 -c libpqmodule.c -o
build/temp.linux-i686-2.4/libpqmodule.o
libpqmodule.c:78:20: Python.h: Datei oder Verzeichnis nicht gefunden
libpqmodule.c:79:26: structmember.h: Datei oder Verzeichnis nicht gefunden
libpqmodule.c:80:24: fileobject.h: Datei oder Verzeichnis nicht gefunden
In Datei, eingefügt von libpqmodule.c:81:
libpqmodule.h:29:22: libpq-fe.h: Datei oder Verzeichnis nicht gefunden
libpqmodule.h:30:28: libpq/libpq-fs.h: Datei oder Verzeichnis nicht gefunden
In file included from libpqmodule.h:33,
from libpqmodule.c:81:
pgboolean.h:44: Fehler: Syntaxfehler vor "PyObject_HEAD"
pgboolean.h:44: Warnung: kein Semikolon am Ende von »struct« oder »union«
pgboolean.h:46: Warnung: »int« ist Standardtyp in Deklaration von
»PgBooleanObject«
pgboolean.h:46: Warnung: Datendefinition hat keinen Typ oder Speicherklasse
pgboolean.h:48: Fehler: Syntaxfehler vor "PgBoolean_Type"
pgboolean.h:48: Warnung: »int« ist Standardtyp in Deklaration von
»PgBoolean_Type«
pgboolean.h:48: Warnung: Datendefinition hat keinen Typ oder Speicherklasse
pgboolean.h:52: Fehler: Syntaxfehler vor »*«-Zeichen
pgboolean.h:52: Warnung: »int« ist Standardtyp in Deklaration von
»PgBoolean_FromString«
.. ... ...
lots of errors
... ... ...

libpqmodule.c:1157: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne
Typkonvertierung
libpqmodule.c:1160: Fehler: Syntaxfehler vor »)«-Zeichen
libpqmodule.c:1160: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne
Typkonvertierung
libpqmodule.c:1163: Fehler: Syntaxfehler vor »)«-Zeichen
libpqmodule.c:1163: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne
Typkonvertierung
libpqmodule.c:1166: Fehler: Syntaxfehler vor »)«-Zeichen
libpqmodule.c:1166: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne
Typkonvertierung
libpqmodule.c:1169: Fehler: Syntaxfehler vor »)«-Zeichen
libpqmodule.c:1169: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne
Typkonvertierung
libpqmodule.c:1172: Fehler: Syntaxfehler vor »)«-Zeichen
libpqmodule.c:1172: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne
Typkonvertierung
libpqmodule.c:1175: Fehler: Syntaxfehler vor »)«-Zeichen
libpqmodule.c:1175: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne
Typkonvertierung
libpqmodule.c:1178: Fehler: Syntaxfehler vor »)«-Zeichen
libpqmodule.c:1178: Warnung: Zuweisung erzeugt Zeiger von Ganzzahl ohne
Typkonvertierung
libpqmodule.c:1193: Fehler: Syntaxfehler vor »)«-Zeichen
libpqmodule.c:1194: Fehler: Syntaxfehler vor »)«-Zeichen
BlackJack

Sonntag 30. Juli 2006, 11:10

Das python-dev Paket fehlt anscheinend auch. Beim selbst kompilieren von Programmen müssen die entsprechenden Development Pakete der betroffenen Programme/Bibliotheken installiert sein.
philippjosefrichard
User
Beiträge: 8
Registriert: Freitag 3. Februar 2006, 06:28

Sonntag 30. Juli 2006, 11:55

BlackJack hat geschrieben:Das python-dev Paket fehlt anscheinend auch. Beim selbst kompilieren von Programmen müssen die entsprechenden Development Pakete der betroffenen Programme/Bibliotheken installiert sein.
Ja, das dachte ich auch schon, aber wo bekomme ich das her?

yum install python-dev findet nichts
auch nicht
yum install python-default



im google habe ich nur
python-dev_2.3.5-11_all.deb
gefunden. F}r Debian. W{re das auch recht f}r Fedora Core3 ? Ich denke nicht.

(rpm -ivh python-dev_2.3.5-11_all.deb
python-dev_2.3.5-11_all.deb: not an rpm package (or package manifest)

Das war zu erwarten.

Wei~ jemand, wo ich python-dev f}r FC3 her bekomme?

Danke
Philipp
BlackJack

Sonntag 30. Juli 2006, 12:13

Schau Dir doch mal alle Pakete Deiner Distribution an, in denen der Name Python vorkommt. In manchen Distributionen bekommen die Development-Pakete auch den Zusatz `devel`.
philippjosefrichard
User
Beiträge: 8
Registriert: Freitag 3. Februar 2006, 06:28

Donnerstag 10. August 2006, 08:55

Zitat: "yum install python-dev findet nichts "

Im FC5 heisst das Paket
python-devel-2.4.2-3.2.1
Antworten