AttributeError: 'module' object has no attribute 'Popen'

Wenn du dir nicht sicher bist, in welchem der anderen Foren du die Frage stellen sollst, dann bist du hier im Forum für allgemeine Fragen sicher richtig.
ivka_sto
User
Beiträge: 63
Registriert: Dienstag 11. Dezember 2007, 23:13

AttributeError: 'module' object has no attribute 'Popen'

Beitragvon ivka_sto » Freitag 2. Mai 2008, 16:35

Hallo,

Ich hab's geschafft, mir python 2.4 zu organisieren (hatte bis jetzt nur 2.3) , und wollte schon sofort mit dem subprocess rumexperimentieren, doch es geht nicht .. Und zwar .. krieg ich folgende Fehlermeldung:

sh-3.1$ ./subprocess.py
Traceback (most recent call last):
File "./subprocess.py", line 9, in ?
import os, sys, subprocess, signal
File "/home/sto/FktTests/subprocess.py", line 38, in ?
subprocess.Popen('ulimit -c')
AttributeError: 'module' object has no attribute 'Popen'


Wie .. "no attribute 'Popen'" .. verpass ich was? Das war das letzte, was ich erwartet hätte ..


Danke euch im voraus :)
Benutzeravatar
Leonidas
Administrator
Beiträge: 16023
Registriert: Freitag 20. Juni 2003, 16:30
Kontaktdaten:

Beitragvon Leonidas » Freitag 2. Mai 2008, 17:05

Wenn du dein Modul umbenennst, denn du hast dein Modul ``subprocess.py`` genannt und importierst es selbst, dann geht der Fehler weg.
My god, it's full of CARs! | Leonidasvoice vs Modvoice
Benutzeravatar
mitsuhiko
User
Beiträge: 1790
Registriert: Donnerstag 28. Oktober 2004, 16:33
Wohnort: Graz, Steiermark - Österreich
Kontaktdaten:

Beitragvon mitsuhiko » Freitag 2. Mai 2008, 18:08

Und lösch auch noch die "subprocess.pyc" weg, wenn du dein Modul entfernst. Sonst importiert er noch das pyc.
TUFKAB – the user formerly known as blackbird

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot]